10 Replies Latest reply on May 2, 2017 9:22 AM by fenushka

    Tried to solve the problem of unabled Discrete graphics card but made it worse

    fenushka

      HP Probook 450 G2

      Discrete card AMD Radeon R5 M255

      Mother card Intel(R) HD Graphics Family

      CPU Intel(R) Core i5-4210U

      OS Windows 8.1 x64

      8 Gb RAM

       

      (pardon my english pls)

      It all started when i've suddenly understood that my PC always uses mother videocard instead of discrete (even when power is on)
      Looking threw AMD settings gave a conclusion that it should work cause everywhere was written "to use maximum grafic effectiveness" but it did not.

      Then i decided to power off the mother Intel video card as people advise. It all went good until i tried to start any videogame. They all made different errors all conected with videocard.
      So I decided to make drivers fresh. I have downloaded radeon crimson relive 17.4.3 minimal setup....

      The first thing Ive seen was "The grafics card is pending". Googling made zero results what does it mean. But anyway i found update button and after waiting for few mins saw "1603 error. During driver downloading we came up with common error (smth like that)". On AMD site it was said to

      1) sfc/scannow

      2) dsim /online/cleanup-image/restorehealth

      3) update windows

      4) Delete AMD drivers in a bud and download them from official site

      5) turn off antivirus (I had only mother windows one)

      All these 5 actions lead to million errors and problems so I decided to clean system back to factory settings deleting everything cause i had nothing to lose.

      Well now my system is clean as a baby.

      all actions now were made absolutely successfull. radeon crimson relive 17.4.3 minimal setup.... updated me successfully but on 16.x.x.x version.
      I could update it to 17.4(if i remember correctly).x.x. but only clicking button to find new version let me do that. But it was failed with an error (i dont remember it sry).
      So i decided to download 800mb full version of updates whql 8.1. 64 bit radeon software crimson relive 17.4.3 -apr 17.exe

      I hoped to find a large menu of AMD Catalyst Control Center where i'd have an opportunity to do all I want as on screenshots from AMD site.
      But after downloading i got same 3 boring buttons to update , system info, settings and follow AMD. (Smth like that i dont see it now it's deleted)
      The only difference from previouse version was that it successfully updated to 17.4... with no problems and errors.
      But after that BSOD with "irql not less or equal" appeared every time i open videogames apps (for example even opening battle.net).

      Trying to make drivers of previouse version (or deleting) threw windows device manager gave BSOD with "kernel security check failure".
      So i've just deleted "AMD software" threw win app deleting and deleted c:\program files(64)\AMD folder. then i've deleted AMD radeon from windows device manager.
      Rebooting my PC i found it working (unabled) and with default drivers which system made while rebooting (As i understand).
      Now Everything works correctly...but...with mother videocard. Not with AMD radeon discrete card.
      So looks like Im "back to square one".
      And I'm afraid to do smth until u reccomend me my next steps.
      Pls help me to make my system use discrete card when I want to (always when charging is on as normal people do i guess).
      sincerely yours,
      Artiom.
      And pardon my english one more time pls!