0 Replies Latest reply on Apr 13, 2017 12:41 PM by altex

    Blurry & flickering screen when set to 1080p, shows 1080i instead

    altex

      Hello AMD community,

       

      Nearing the end of last year, I built a custom entry-level gaming PC to fulfill my basic gaming needs until I get my dream gaming PC at the end of this year. Now, I've had this problem since the very beginning - when I set my desktop resolution to 1920x1080, my display changes to 1080i and things get blurry. The screen starts to flicker. I am using a Sony Bravia TV as my display device, and this is the only display device I currently own. I've enabled "Virtual super resolution" in AMD Radeon Settings. This allows me to set my desktop resolution to higher resolutions than what my display supports. My TV is capable of displaying 1080p @60Hz max. Now, the confusing part here is that when I set my desktop resolution to "Virtual 2K" (2560x1440), the TV's output changes to 1080p and everything's as sharp as it should be. But I want to keep my resolution at 1080p, because at 2K resolution, most apps appear to be extremely small, which I find difficult.

       

      What could be the cause of this problem? Is there anything I can do to fix it? Is there anyone else who is facing this blurry/flickering screen problem? Please help.

       

      Help needed,

      AlTeX

       

      System specs:

      • Intel Core i3-4130
      • MSI Z97 PC Mate motherboard
      • 12GB DDR3 RAM
      • Corsair VS450 450W PSU
      • ASUS ROG STRIX Radeon RX460 OC 4GB GDDR5 GPU
      • Seagate 500GB HDD
      • Transcend 120GB SSD