2 Replies Latest reply on Apr 16, 2017 1:34 AM by tronlaser

    All games exhibit strange stuttering and CPU clock drops

    tronlaser

      Video demonstration: https://www.youtube.com/watch?v=Qs7jsDgXjHs

       

      This happens with any game but GTA V shows it most obviously. When not occurring the game runs at a perfectly stable sixty frames per second, this issue occurs precisely every 60 seconds, and lasts for the same duration each time. The CPU clock speed suddenly divides itself by a third and the framerate halves. I'm running the latest build of Windows 10, with the latest NVIDIA GPU drivers. Any help would be appreciated. The specs of my machine can be seen in the video.

        • Re: All games exhibit strange stuttering and CPU clock drops
          savagebeastzero

          Hey tronlaser,

           

          Everything that follows is simply a theory, but I believe a correct theory nonetheless. After studying the data, the issue being encountered appears to be you're exceeding your Vram by a vast amount. No worries, this isn't a knock on the Gtx970 3.5GB Vram debacle, read on...

           

          GTAV when operating at the settings shown in the video requires far more Vram than you posses, (even though it states that it's only preparing to use 2.319GB Vram in total) thus the textures and all its associated properties must then be streamed via the system memory and your virtual page file, which creates a noticeable hitching during the exchange of data as the CPU processes the information whilst also handling other important system tasks which correlate to its operation to attempt to provide the experience to you such as driver based tasks.

           

          The reason it appears that every 60 seconds the same issue is exhibiting itself is likely due to the streaming data occurring at roughly the same interval and it takes roughly the same amount of time for your system for process it all. I believe this is much more likely to be the case than anything specifically tied to a hardware fault, system or user error.

           

          Let me guess, you were able to operate the title with these settings and same components previously, right?

           

          Normally, the texture streaming wouldn't be an issue in GTAV with your components and your video cards Vram amount, because texture streaming would operate properly as originally intended, optimized for your components but.....

           

          Recently GTAV received an update that has caused many users both Nvidia and AMD performance issues no matter the performance tier. Previously, you and others were likely able to operate the title without noticing the hitching much, causing you less disturbance when playing, but now after the update, it's become more pronounced, causing a less than optimal experience. The texture streaming issue is what I believe is affecting many regardless of hardware tier to differing degrees, so I don't think this will remain in this state for long...hopefully.

           

          For the time being, I recommend that you specifically reduce either your texture quality, rendering resolution, AA or all if you can stomach it. File a bug report with Rockstar, provide them with the video and hopefully they'll figure out where the texture streaming issue resides soon, so that your experience can return to its previous state.  If I were you, I would await a patch that resolves the issue and returns the game to its previous state. I'm sorry that I couldn't offer you a more definitive solution, but many of the issues depicted and data recorded in that video are truly out of my hands in resolving or at least it appears to be the case in my opinion.

           

          This truly appears to be a Rockstar issue this time around I'm sad to say, good luck.

          1 of 1 people found this helpful