7 Replies Latest reply on Apr 10, 2017 1:16 PM by jayboz6989

    ULPS Doesn't Save or Always Work

    jayboz6989

      I have two R9 290's that are watercooled and I am having trouble keeping the ULPS mode enabled.  It seems to turn on and off randomly between restarts.  I have disabled ULPS in both msi afterburner and regedit.  I also tried in Trixx too and setting each card individually.  I am using the latest driver from AMD 17.4.1.  There seems to be a bug because my second gpu either stays at 300 MHz (150 MHz memory) or has zero activity.  Then randomly I will restart and it will be working for a bit and then cut out. I believe my overclock is stable too.

       

      I can run a benchmark and get one number then run it right after and get a completely different number.

       

      Anyone have a consistent way to keep ULPS active?

       

      Thanks

        • Re: ULPS Doesn't Save or Always Work
          kingfish

          Yes. Get rid of all the conflicting third party controllers. Use regedit .

          Also, it must be disabled after each new driver is installed.

          2 of 2 people found this helpful
            • Re: ULPS Doesn't Save or Always Work
              jeztur2003

              This is exactly the kind of issues I made a post about no way should we have to tamper with the registry to provide the correct amount of power to our crossfire setups.

              1 of 1 people found this helpful
              • Re: ULPS Doesn't Save or Always Work
                jayboz6989

                Thanks Kingfish for responding.  If I get rid of MSI afterburner then I won't be able to clock the gpu's though.

                 

                Were the original values for all EnableULPS_NA set to 1?  Perhaps I screwed up my registry when I thought changing those would help.

                  • Re: ULPS Doesn't Save or Always Work
                    jeztur2003

                    All the na's are originally set to 1

                    • Re: ULPS Doesn't Save or Always Work
                      kingfish

                      Afterburner and the rest of these controllers are the reason AMD developed Crimson/ReLive control panel. Years of complaints from 'users' who complained AMD should offer this ability and not have to rely on third party apps to do it. Now you have it....but don't use it. Companies like MSI and Asus have bundled controllers with their graphics cards for years because before ReLive you had to have something. Nevermind that Afterburner (and the others) settings conflict with Wattman settings and cause all sorts of issues....people continue to use it because that's all they know.

                      Afterburner has a learning curve. It's not that easy for a novice to determine what he should be changing...or the consequences of changing it.

                      The same holds true for Wattman. You have to learn it just like you did with the other controllers. AMD doesn't make it easy...they have never explained any of their setting options. They have even mis-named a setting ...."Target Temperature". Biggest mistake ever. Now you have people setting it at 70-80c and complain fans don't work right to keep the GPU under the "Max" temperature. Then they start screwing with the fan settings.

                      The forum is full of "issues" with Wattman. The real issue is the person sitting in front of the keyboard...in the majority of the cases.

                      I recommend getting your graphics card running correctly before changing any clocks or fan speeds. The only exception is the Power Limit...which should be set to maximim,,,+50. This is a must if you are going to game or overclock.

                      ULPS: How to disable  There shouldn't be too many (1or2) instances of EnableULPS_NA....but those should be left at default  1 ...don't change them.  Try opening the command prompt as ADMINISTRATOR when opening regedit for the settings to stick.

                      Try disabling any third party apps. Set the Relive settings back to default...using the default set button. Then only change the temp to 'manual'...change the MAX temp (only) to 80c and the Power Limit to +50. Thats all. All fan settings and controls left at automatic/default settings. Click 'apply'. Play a game with Hardware Monitor running in the background. After playing , check your max temp and fan speeds. If everything is working well, then you could try any overclocking, etc...if that is your desire.

                       

                      Screenshot_1 (10).png

                       

                      Screenshot_2 (6).png

                       

                      OLD VERSION: Notice 'target temp' minimum:

                       

                      Screenshot_1 (8).png

                       

                      AMD graphics performance

                      1 of 1 people found this helpful
                        • Re: ULPS Doesn't Save or Always Work
                          jayboz6989

                          Thanks I didn't realize that Wattman was capable of setting everything.  Got everything working correctly now too!

                           

                          For anyone else who has the problem remove Afterburner and control via Wattman (which is under Radeon Settings -> Gaming -> Global Settings)  then just set your clocks to the ranges you want.

                          1 of 1 people found this helpful