AnsweredAssumed Answered

VERY weird Ryzen+RX480 system behavior, please help!

Question asked by abheekg on Mar 31, 2017
Latest reply on Jun 2, 2017 by ajlueke

Hello all,

 

Firstly, thank you to anyone reading this with a helpful intent, I’m very grateful to have a good online community to turn to in such times.

 

My system specifications are as follows:

AMD Ryzen 7 1700 @ stock

GIGABYTE AB350-Gaming 3 with latest F5 BIOS

Corsair LPX3000 8GBx2 DDR4 memory (does not run above 2166 L)

MSI RX480 4GB

Corsair RM750x Power Supply

Samsung 850 EVO 250GB SSD as OS/Applns drive

Western Digital 1TB 7200RPM Blue Hard Drive

Windows 10 Home x64 Operating System

 

My problem is as follows:

 

On installing windows, everything worked great. I installed Far Cry 4, Fallout 4 and Wildlands, all worked very well: Far Cry 4 @ 50-70FPS Very high settings, Fallout4 @ 45-60FPS Ultra and Wildlands @ 45-55FPS Very High settings, all on 1080p. I shut down the machine, and on restart all games had degraded, FC4 gives nothing above 20 FPS, Fallout4 stutters wildly, and Wildlands just crashes. I run a basic CPU-Z benchmark, single core scores ~2000, as expected, and multicore gives barely 5000. I check that R7 1700 generally gives 16000 on this. Checking in the task manager, CPU-Z also peeks processor usage at 45%. I enable the High-Performance power plan, reinstall display drivers, and even uninstall the processor from Dev Manager and restart: no luck. Desperate, I reinstall windows: all back to normal. CPU-Z @ 16000 and FPS back to old levels. I shut down and restart the machine, still all good. But then after gaming, CPU-Z drops back to 5000 score, CPU usage to 45%, but I recheck FC4 and it’s still solid.  So CPU-Z and FC4 are not related, hmm. Relieved, I call it a day.

 

Next morning the computer boots, Windows informs me it’s corrupt, and a GIGABYTE splash screen stating, “ATTEMPTING REPAIRS” sticks around for a bit. Restarts then, performance degraded as before. Exasperated and in no mood for this, I reinstall windows, all back to normal once again. I spend the day shutting down the rig, switching off the mains and restarting. All stays solid. I get SiSoft Sandra and Cinebench R15. Benchmark over 10 times throughout the day. Cinebench consistently gives chart topping performance, a CPU score of 1350+ every time. The Cinebench OpenGL test does the same, top performance on the small list they display to the left with a score of 80+ FPS each and every time. FC4 stays above 70 FPS. All good. The system has been cold booted several times, benchmarked several times, all seems solid. I start the computer at night: performance degraded, Far Cry 4 back at 20FPS, CPU-Z at 5000 multicore. But here’s the funny thing: Cinebench sticks to its old scores of 1350+ CPU and 80FPS+ GPU. Once the GPU score dips to 76, but then stays above 80 consistently after that. I use DDU to remove the display drivers using Windows Safe Mode and re-download and install them: no luck. High Cinebench score, ultra-fast bootup and systems response. Far Cry 4 degraded heavily. 

 

  It’s late and night and I need to work the next day, so I give up for the day. I come back today evening, and check what’s up, Cinebench R15 CPU test gives 1367 (perfect), the OpenGL test gives an all-time high of 93FPS. Curious, I try Far Cry 4, it’s back to 55-70 FPS. CPU-Z? Single core: 2000, multicore: 1800!

 

Really, what is going on here guys? I’d be so grateful to anyone shedding some light on what this could be. I also changed the PSU cable and plugged it the GPU into a different power slot: nothing had changed last night. I don’t understand what’s wrong because if there were a hardware problem, how would it do so well with CPU & GPU @ 100% use on Cinebench, but suck everywhere else? 

While it’s working well now, I don’t want to wait to be bewildered by another random screw up…insights and help please!!

Outcomes