4 Replies Latest reply on Apr 7, 2017 5:56 AM by mattclay

    144hz @ 1440p display link failure - not cable/device related

    descended

      Hi AMD,

       

      I'm just posting so AMD is aware they have a problem with their drivers when using 144hz @ 1440p. 

       

      I purchased an Asus MG279Q monitor which is an 144hz@1440p IPS display.  I currently own an XFX RX 480 8GB and cannot play games at 1440p and >90hz.  I have an Asus 144hz1080p screen and it works perfectly fine.  If AMD can prove that there isn't a problem with this kind of setup, then I'll send it back.  However, this is the second mg279q to do this, only the second one I've tested with 3+ cables.

       

      I'm currently using windows 10 pro and have installed roughly 10 different versions of radeon software on entirely fresh installs of windows.  During these tests I've used 4 different DP 1.2 cables, all certified according to the DP website and two cables from this thread.  https://www.reddit.com/r/pcmasterrace/comments/3uvp02/a_holiday_reminder_on_quality_displayport_cables/

       

      I will live with the fact that it will not work and that's ok for now.  My problem is when VEGA comes out and it has the same issues, I may switch to green as I am an avid FPS player and need those extra 54hz.  And yes I do realize I have a freesync display, so buying green would be horrible...plus hyprocritical as I own about 10k in AMD stocks :S

       

      My Setup / old one (same problems)

      1700 @ 4.05 / 8350 @ 4.9

      Asrock killer / Asus 990fx

      Tridentz DDR4 3200 (@2666) / DDR3 1866

      XFX RX 480 8GB, liquid cooled (custom) @ 1490/2270

      EVGA 850 G2

      Samsung 850 pro

      Windows 10 pro (latest patches..ish)

        • Re: 144hz @ 1440p display link failure - not cable/device related
          mattclay

          Hi Descended,

           

          I'm having similar problems. I am able to play games at 144hz1440p, but I seem to get displaylink failures when the monitor switches between 1440p and 1080p, or fullscreen and window mode or alt+tabing out of fullscreen.

           

          I have an MSI RX 480 8GB Frozr version, and have RMA'd one card already. I have the same Asus MG279Q monitor, and like you I have tried many driver versions and configurations on install, along with different DP and miniDP cables (currently using full DP Startech cable), and clean installs of Win 7 and Win 10. I fared better when I just installed the driver and none of the additional software, but with my newer card it seems to be less sensitive to this so I believe the first card was in fact faulty.

           

          Since changing the card I have yet to experience any crashing, but whenever I have a resolution or window mode swap, it's 80/20 as to whether I will get this Displaylink failure. Once I have this displaylink failure, I cannot go above 60hz until I reboot and is a major PITA.

           

          I'm very keen to see if there is any response from AMD on this one as there seems to be a problem with this graphics card and monitor combination when trying to use 144hz.

           

          Specs:

          Intel i5-3570k (no overclock)

          Asus P8Z77-V

          MSI RX 480 8GB

          • Re: 144hz @ 1440p display link failure - not cable/device related
            jurban89

            I am having the same issues as you guys. My gtx 980 died 2 weeks ago so I grabbed an rx480 8gb from Best buy for the time being. I only have had this issue in h1z1 and PU Battlegrounds. I don't have this issue when I play CSGO. When I turn on freesync, my monitor locks to 89.9hz, and I am able to play games, but the moment i turn off Freesync and play at 144hz, my monitor flickers and resets itself to 60hz. I don't even have an option to change it from 60hz back to 144hz until I shut down the game and turn off and on my monitor.