1 Reply Latest reply on Mar 28, 2017 10:51 AM by arcticwind

    RX480 Compatibility?

    r0hda

      I've got an old Lenovo M91 that I gutted and threw into a regular mid-tower case, along with a 630w PSU, 16gb of memory, and a 2gb R9 270x card (thanks Pat!). Everything worked great and the 270x was a decent enough card for what I needed, but on impulse I decided to pick up a reference 8gb RX480. However, the computer won't boot with the 480.

       

      • With the 480 in the PCI-e slot AND hooked up to the power supply, it won't boot. There's no video output, no POST, no beep codes, nothing. All of the fans including the GPU blower spin, but that's all. I know it's not booting at all because just pressing the power button immediately turns the computer off, rather than having to hold the button for a few seconds.
      • With the 480 in the PCI-e slot but NOT hooked up to the power supply, the computer will boot and run with the integrated graphics. The 480 isn't detected by Windows in Device Manager, DxDiag, or AMD Software.

       

      The card works just fine in a friend's (somewhat similar) rig, so I know it's an issue with the rest of the computer and not the card itself. I've tried everything I can possibly think of and everything I've found in other forums, but I still can't get it to even POST.

       

      Computer Specs -

      • Operating System: Windows 10 Pro 64-bit (10.0, Build 14393) (14393.rs1_release_inmarket.170303-1614)
      • System Manufacturer: LENOVO
      • System Model: 4480B1U
      • BIOS: 9HKT58AUS - dated 6/28/2014
      • Processor: Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz (4 CPUs), ~3.1GHz
      • Memory: 16384MB RAM
      • Chipset: Intel Q67
      • PCI-e: 2.0 x16
      • PSU: 630w

       

      Here's what I've tried so far -

      • Yes, everything is plugged in all the way.
      • Setting the display device to PEG instead of Auto in the BIOS.
      • BIOS update - since the last update was from 2014, maybe that's the cause?
      • Clean UEFI install of Windows 10, since I later learned the 270x has legacy support but the 480 doesn't. (correct?)
      • Triple checked UEFI boot in the BIOS and made sure there is an EFI partition in Disk Management, just in case.
      • UEFI BIOS update - also from 2014.
      • Switching the BIOS to integrated graphics and powering on the computer with the 480 plugged in. Still no video output from either source.
      • Pulling RAM in different combinations, unplugging unnecessary peripherals, etc.

       

      I'm completely stumped. If I had to guess, it would either be BIOS incompatibility, chipset incompatibility, or something with the PSU. But if the PSU can run the 270x, that can't be it, right? Help!

        • Re: RX480 Compatibility?
          arcticwind

          Lenovo like to use OEM motherboards in their systems, these usually have very specific limits on compatible item that can be used with them.

          Check with Lenovo to see if it is compatible with the new RX480 GPU's and also if there is an updated BIOS for it.