AnsweredAssumed Answered

ryzen still not working....

Question asked by slayer071680 on Mar 24, 2017
Latest reply on Mar 30, 2017 by slayer071680

ok, this is the third asrock mobo. i have had 2 x370's and 1 b350 asrock boards. and non have worked. i have 2 ryzen cpu's. i have tried putting ram in a1, a2, b1 and b2. and nothing happens. bios does not post to screen and mobo flashes a red light. i have used jumpers to clear cmos and after i clear cmos the light on mobo will turn green for a second then returns to flashing red. i have monitor plugged directly into graphics card (i know graphics card works cause i have tried it in a different computer). i also have different sticks of ram from a different company, just in case ram is bad. but either way, computer does not post bios or boots up and board just flashes red. i took it to a computer store for exact same reason before (the computer store determined it was either bad mobo or cpu) and i got a second 1800x from amazon as a result to rule out bad cpu. so now i am stuck. i honestly don't know what to do. everything is plugged in correctly, mobo is not touching case, there is no grounding issues. i am completely stumped and baffled. is it just asrocks are selling bad boards? below is a video i made showing whats going on.

20170324 182536 - YouTube