4 Replies Latest reply on Jan 20, 2018 1:51 AM by msscha01

    480x link failure error message

    trilas

      I have just recently bought an Asus 480x and a Samsung C27FG70 monitor supporting 144hz and freesync. When I use a displayport cable and activate DP 1.2 in the monitor menu I get the following error message bu the Radeon software "The system has detected a link failure and cannot set the requested resolution and refresh rate on your DisplayPort display. Your display might not support the requested resolution or there may be an issue with the cable connecting the display to your computer".

       

      Now the first thing that comes to my mind is the cable. Have been trying about 5 or 6 different displayport cables of different lenghts...still get the same error message. When I use a HDMI cable, which only support 120hz on the monitor, I don't get the error message anymore. Is this a problem in the software?

       

      I'm running Windows 10 64 bit and have the latest drivers installed...

       

      Please help!