5 Replies Latest reply on Mar 28, 2017 1:51 PM by amdmatt

    R9 290x on Ubuntu 16.04

    simon9100

      Hello there AMD community!

       

      I'm kinda new here and i believe this post should come here, correct me if im wrong!

       

      Okay to start of, I am new to ubuntu and I would like to install the best drivers possible for my 290x card in linux ubuntu 16.04. If i read everything correct, the amdgpu-pro drivers should be possible for me to install. But if I follow the procedure written down at the driver download page I end up getting a broken system. What happens is I restart and while restarting the screens hangs at a black screen with a flashing white dash. Tried it multiple times, didnt work for me.

       

      This is what shows when i typ this in the terminal:

      simon@simon-Z87-HD3:~$ lshw -c video

      WARNING: you should run this program as super-user.

        *-display              

             description: VGA compatible controller

             product: Hawaii XT / Grenada XT [Radeon R9 290X/390X]

             vendor: Advanced Micro Devices, Inc. [AMD/ATI]

             physical id: 0

             bus info: pci@0000:01:00.0

             version: 00

             width: 64 bits

             clock: 33MHz

             capabilities: vga_controller bus_master cap_list rom

             configuration: driver=radeon latency=0

             resources: irq:28 memory:c0000000-cfffffff memory:d0000000-d07fffff ioport:e000(size=256) memory:d0800000-d083ffff memory:c0000-dffff

        *-display

             description: VGA compatible controller

             product: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller

             vendor: Intel Corporation

             physical id: 2

             bus info: pci@0000:00:02.0

             version: 06

             width: 64 bits

             clock: 33MHz

             capabilities: vga_controller bus_master cap_list

             configuration: driver=i915 latency=0

             resources: irq:29 memory:d0c00000-d0ffffff memory:b0000000-bfffffff ioport:f000(size=64)

      WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

       

       

      As you can see, i do have a second vga controller which is inside the CPU (?). Maybe this causes troubles? I dont really need the second vga controller, i think.

       

      GPU: R9 290X

      CPU: i5-4670k

      RAM: 8GB of it.

       

      Could you guys help me out here?

       

      Thanks in advance!