6 Replies Latest reply on Mar 22, 2017 4:43 AM by goodplay

    I keep getting error 1603 when installing any of the new drivers

    thierry88

      Hello,

       

      I have a problem with my pc which i'm getting quite stuck at.

      I have the following system:

      Asus M5A99FX Pro R2.0

      AMD FX8370 @ Stock Settings

      Kingston HyperX Fury 4x 4GB 1866Mhz DDR3 @ Stock Ssettings

      Sapphire RX480 Nitro+ OC 8GB @ Stock Settings

      Corsair HX1000i 1000W psu

      Samsung Pro 840 - 120GB ssd - OS

      Samsung Evo 750 - 500GB ssd - Apps/Games

      Samsung 640GB HDD - Storage

      2x Hue+ Digital lighting

       

      I'm running Windows 10 Pro 64bit, All updated.

       

      The Problem:

      I had AMD Driver 16.60.2011 installed and hadn't updated it for a while, few days ago i noticed i could use an update so i downloaded the latest stable version 17.2.1 and started the setup.

      At about 50% the screen goes dark en comes back up (as normal for graphics driver installation, but then it jumps to 100% and gives me the Error 1603 and i only has been partially installed.

      Now i don't have the AMD software on my pc and cannot change any GPU settings.

      I also tried the 17.3.2 driver and that does the same, also i tried all the steps from the page that is suggested how to fix this, like registry check, windows update, checking user rights, removing old drivers using AMD Driver Removing tool.

      Now i'm getting a bit stuck here and i'm not sure what's going on.

      I guess it conflicts with some software on the machine.

      Maybe the Sapphire Trix software? i tried closing it but no effect. or the Hue+ which has a hardware monitor/overclocking function build in (which i don't use atm).

      I do have MSI Afterburner installed but it's not running or active or anything.

       

      If you need any more information, please ask and i will provide as much as i know.

      I really hope we can solve this one.

       

      Greetings,

      Thierry de Bakker.