8 Replies Latest reply on Mar 13, 2017 3:12 AM by kingfish

    Can't access settings "No Graphics Driver Installed or AMD Driver is not functioning properly. Please Install the AMD Driver appropriate for your hardware." GPU seems to be working otherwise, but settings refuse to open and Host application crashes if I t

    contrabardus

      Radeon HD 7970 6gb Ghz Edition, Windows 10 Home x64, 16 GB RAM, i7 3770k, +200 GB available space on the SSD my OS is on. I have two cards, but Crossfire is not enabled. Part of the problem is that I can't turn it on or off because I can't access the settings. The GPU is running though, and works as I can run games and programs I would not be able to if it wasn't.

       

      I have the latest drivers installed, and they were working fine yesterday. Today I suddenly cannot access the AMD settings. I know for a fact this same driver was working fine because I was messing around with the profile settings for Hard Reset Redux with it a couple of days ago.

       

      I am the admin and always install/uninstall and run command prompts as administrator.

       

      My Windows updates are up to date and don't show any failures in my update history.

       

      When I try to access my AMD Radeon Settings I get this error:

       

      "No AMD graphics driver is installed, or the AMD driver is not functioning properly. Please install the AMD driver appropriate for your AMD hardware."

       

      A short time later the red Radeon Settings icon disappears from the system tray. It doesn't vanish until after I try to open the settings menu and it fails.

       

      Radeon Additional Settings: Host Application and Radeon Additional Settings Monitoring Program are both visible in the task manager.

       

      AMD External Events Utility is stopped in services and won't start. Attempting to start it brings up this error: "The operation could not be completed. The service did not respond to the start or control request in a timely fashion."

       

      Searching for AMD Radeon Settings brings up the program so I can attempt to start it and it brings up the driver not installed error again. The AMD Host Application will temporarily appear in the Processes tab of the Task Manager, but vanishes after a short time after the error pops up.

       

      Right clicking gives me two options. "Radeon Pro and Firepro settings", and "Radeon Pro and Firepro Advanced settings".

       

      "Radeon Pro and Firepro Settings" acts just like trying to launch the settings from the system tray icon. It brings up the error.

       

      "Radeon Pro and Firepro Advanced settings" just gives me the little spinning wheel icon for a second or two and does nothing.

       

      I have uninstalled and reinstalled several times. I've Uninstalled from Device Manager, Programs, and using DDU and AMD Cleanup Utility in safe mode to take everything out multiple times. I disabled my Firewall, antivirus, and antimalware to install the drivers. The error still persists.

       

      I deleted every AMD folder that was left behind by DDU in Appdata, C\:, and both Program Files folders.

       

      I've tried three different versions of the drivers and attempted to roll back to versions that were working previously. Drivers 17.3.1, 17.2.1, and  17.1.1 all behave the same way. I also downloaded the 17.3.1 and 17.2.1 a few different times just to be sure it wasn't a corrupted download, same result. Tried the minimal, Relive, and auto detect downloads.

       

      I am sure I have the correct drivers from the AMD website, I've checked and rechecked this multiple times. All of the drivers I've tried were working with this same hardware before this issue popped up, including the newest one.

       

      Rolling back my PC using system restore does not make the error go away. Had a restore point from when I know for a fact it was working, didn't change anything.

       

      I've run SFC/Scannow and DISM scans. No errors.

       

      Tried installing Microsoft Visual C++ 2005 SP1 Redistributable Package (x64) as it was listed as a possible fix for this error somewhere else. Did nothing.

       

      Tried disabling digital signatures and did another uninstall and reinstall as it was another possible cause. That didn't pan out either.

       

      Trying to install the drivers in Safe Mode results in an "Error 99 – AMD Installer Cannot Continue Because the Driver has not Been Digitally Signed" message in the AMD driver installer window. This happens in Safe Mode even if I have Digital Signatures disabled through the Command Prompt.

       

      The digital signature error does not come up if I install the drivers after a normal boot whether Digital Signatures are enabled or not. The drivers install and seem to work fine, except for me still being unable to access the AMD settings due to the "No graphics driver installed" error.

       

      Malware, Adware, and Virus scans all come up clean. Scanned with CCleaner for registry issues after uninstalling using DDU and nothing came up.

       

      Device Manager says my software is up to date and lists the Drivers as AMD and not generic. No yellow sign icon.

       

      The GPU is on and working. I can run Doom 2016 and get well over 60fps at Max Settings running it on Vulkan. My onboard GPU cannot do this.

       

      I have no idea what is wrong, it just won't load the settings menu anymore for some stupid reason, the GPU itself is running as it should as far as I can tell. I can monitor it with OpenHardwareMonitor and the temps and everything are all the same as they usually are. Games run and perform just like they did before this issue came up.

       

      Game Profiles I set before the settings decided to not let me in anymore seem to be working, I just can't make any new ones or tweak existing ones, so I can't disable or enable crossfire, turn V-sync on or off, or any number of other little tweaks I'd like to be able to do for my games. I deleted the AMD profile folders just to be sure the issue wasn't from some corruption in them, but backed them up beforehand and replaced them after removing them proved to have no impact.

       

      This has been driving me nuts. I noticed it yesterday because I wanted to turn V-sync on for Painkiller Black Edition because the physics in that game don't work right if the framerate is too high. There is no in game setting for it and I don't want to use the console command every time I boot the game, so I figured I'd turn on V-sync through the Radeon settings menu only to find it would not open anymore. Absolutely stuck and annoyed by this. No amount of uninstalling, reinstalling, or downloading another copy of the drivers fixes the problem, and the usual troubleshooting routes have all been dead ends. Any idea how to fix this?