AnsweredAssumed Answered

amdgpu-pro16.60 after installation problem

Question asked by bluefoxzero on Mar 9, 2017
Latest reply on May 22, 2017 by rjd

I am running Ubuntu16.04.2 LTS and have AMD Radeon R7 M265 GPU. Recently I tried installing amdgpu-pro 16.60 driver following the instructions from AMDGPU-PRO Driver for Linux Release Notes. But after rebooting I couldn't login (it would loop back again and again to the login screen). I tried a workaround for this at drivers - Can't login after installing AMDGPU-PRO 16.60 - Ask Ubuntu which says to use --px option while installing. This would enable to login(I don't know why). Also I was able to find the amdgpu driver using lspci command and "dpkg -l amdgpu-pro".

But now I cannot find it as a OpenCL recognized device when I run the command "clinfo". I looked into forums with suggestions like adding the libOpenCL.so library installed by the driver to LD_LIBRARY_PATH but nothing worked. I don't know where the problem is. I basically want to use OpenCL to access my GPU.

Outcomes