8 Replies Latest reply on Apr 6, 2017 3:18 AM by jeztur2003

    Asus RX480 Crossfire & Driver problem

    stormshadow2100

      Hi All.

      I new to this Forum so hello to you all.

      I joined in hope someone here is having the same issue as me with my Asus Strix RX480s (pair)

      So I purchased a pair of Asus ROG Strix RX 480 8GB OC just recently & its just been a nightmare with Crossfire & drivers!!

       

      My system is

      AMD FX 8370

      970 PRO GAMING/AURA

      Asus ROG Strix RX 480 8GB OC X2 (Crossfire) 

      HyperX Fury DDR3 1866 16GB

      HyperX Fury 120GB SSD

      HyperX Savage 240GB SSD

      Seagate Barracuda 1TB HDD

      Corsair RM850x 

       

       

      I'm was currently using AMD driver 17.2.1. & during install the driver crashes due to both cards being powered on !! (this has happened more than once)..

      The only work around was to leave one RX 480 powered on to fully install said AMD driver....& even then ,once the driver is fully installed & powered up the 2nd RX 480 the system crashes until I press the reset button on my pc at least twice.

       

      My other issue is the Crossfire toggling....When I disabled Crossfire the system is fine but when I enable Crossfire the driver freezes my system with the said AMD driver 17.2.1.

       

      I have tried all the following ...used AMD clean up utility for a fresh install , reinstalled fresh Windows 10 home 64 , tried previous drivers all with still the same problems!!!

       

      I'm getting to a point where I wish there was some kind of fix for all of this but it seems there is not ??

      I noticed that under the AMD Known issues for driver 17.2.1 its mentions the following ...Radeon Settings may crash on switching Windows® user after toggling AMD CrossFire™ technology mode.....Is this what I'm experiencing here ???

       

      I would like to mention I even updated to AMD's newest driver Crimson ReLive Edition 17.3.1..again same problems!! What is going on ???

       

      And for those having FPS issue here with the same GPUs as me ..Do not install GPUTweak2 as I found this to be the main issue.

       

      Any help would be greatfull

       

      Cheers guys.