AnsweredAssumed Answered

R9 290X Driver Issue

Question asked by xuan on Mar 5, 2017
Latest reply on Nov 16, 2017 by sujitubhi05

I have been happily using my R9 290X for many years and updating the drivers as I go with no problem, then comes the latest driver 17.2.1.


Motherboard: MSI Z170A-G45 Gaming

CPU: i7-6700k 4.00Ghz

Ram: 8 GB

GPU: Sapphire R9 290X 4GB

OS: Windows 7 64-bit with Service Pack 1 on Samsung SSD 840 EVO 250 GB



Problem 1: Installed 17.2.1, rebooted computer back into windows all works fine, then some screen tearing and this error message “Display driver stopped responding and has recovered” then BSoD. Windows reboots and after the first Windows splash screen just a black screen and nothing else.


Problem 2: After installing driver and restarting computer, Windows reboots and after the first Windows splash screen just a black screen and nothing else.


Attempt 1.

Rebooted into Safe Mode

Used DDU to remove any old drivers

Rebooted back into Windows

Make sure all Windows update are installed

Clean Registry using Ccleaner

Disable all antivirus software

Install 17.2.1 in administrator mode

Back to Problem 1.


Attempt 2.

Rebooted into Safe Mode

Used DDU to remove any old drivers

Rebooted back into Windows

Make sure all Windows update are installed

Clean Registry using Ccleaner

Disable all antivirus software

Install 16.9.2 in administrator mode

Back to Problem 2.


Attempt 3.

Clear CMOS

Rebooted into Safe Mode

Used DDU to remove any old drivers

Rebooted back into Windows

Update all BIOS to latest version.

Clean Registry using Ccleaner

Disable all antivirus software

Install 16.9.2 in administrator mode

Back to Problem 2.


Multiple Attempt

Rebooted into Safe Mode

Used DDU to remove any old drivers

Rebooted back into Windows

Make sure all Windows update are installed

Clean Registry using Ccleaner

Disable all antivirus software

Install the following drivers (15.12, 15.6, 16.12.2, 1611.5) in administrator mode

All Back to Problem 2.


Now stuck with “Standard CGA Graphics Adapter” and attempt to install any AMD driver throws me back to problem 1 or 2.


I have backed team RED for many years now, yes I know your drivers can be problematic in the past, but nothing like this. Any help would be appreciated.

Outcomes