AnsweredAssumed Answered

RX 480 DISPLAY PROBLEMS IN BIOS/UEFI AND WINDOWS

Question asked by dustyh on Mar 5, 2017
Latest reply on Mar 7, 2017 by jeztur2003

Hi all! First, thanks in advance for any suggestions anyone can offer.

 

I just built a new PC, and am having problems with the RX 480. Specs:

 

MOBO: Asrock H170M-ITX/DL

PSU: Corsair CX430W Bronze

RAM: G.SKILL Ripjaws V Series 16GB (2 x 8GB)

CPU: Intel Core i5-7400 Kaby Lake Quad-Core 3.0 GHz

GPU: PowerColor RED DRAGON Radeon RX 480 AXRX 480 4GBD5-3DHDV2

 

History: I purchased all of this from Newegg a couple of weeks ago, got it all assembled and ran into problems immediately - no startup. I realized that the motherboard BIOS version was not compatible with the Kaby Lake CPU. I swapped the CPU out of another computer and flashed the BIOS to the new version that provides support. That was a success, and I finally got into the UEFI. The problem? It looks like this:

 

http://imgur.com/a/SjclN

 

OK, that's bad, but I went ahead with Windows 7 (Ultimate x64) installation, hoping that graphics drivers would resolve the problem (but if it looked that way in UEFI, my hopes weren't high). I grabbed the latest drivers, installed them, aaaand:

 

http://imgur.com/a/l3HHo

 

No, still happening. The card doesn't appear to be functioning in this machine. I pulled it and stuck it into an older computer, installed the drivers, and it worked. The CPU in my older computer is an old AMD Duo, so the performance wasn't super great - I couldn't tell if the RX 480 was fully functioning or not, hard to say. No red static though!

 

I took a GTX 750ti that I had lying around and put it into the new machine - it works just fine. Same HDMI cable, so that's not the culprit either. Installed the NVIDIA drivers and it's working great. So the PCIE slot on the new MOBO is functional.

 

Next, I thought that maybe it was a PSU issue. The new PSU is only rated at 430W (but this is a mini ATX build with a single case fan - 430 should cover it, I think) so I thought I'd try it with a 500W ANTEC. Same red, distorted results.

 

I'm out of ideas, so I've got the card ready to RMA to Powercolor. I can't send it in to Newegg for a swap because I'm a big idiot and already mailed in the rebate (with the original UPC and S/N on the retail box) so they won't take it back. Powercolor called me to verify that I had done some troubleshooting, and I went back and re-seated the card just to see if it would magically work, but it's still the same.

 

ANY ideas or suggestions on what I may have missed would be awesome. I plan to wait a few days before I mail the card out, because the whole RMA process can take up to 15 business days.

 

Thanks in advance!

Outcomes