1 Reply Latest reply on Mar 4, 2017 7:03 PM by yurtesen

    Ubuntu 16.04 AMDPRO-GPU not installing

    yurtesen

      I am trying to install amdgpu-pro-16.60-379184 on Ubuntu 16.04 following instructions at How-To Install/Uninstall AMD Radeon™ Software AMDGPU-PRO Driver for Linux® on an Ubuntu System

       

      But it ends with:

       

      Reading state information... Done

      Some packages could not be installed. This may mean that you have

      requested an impossible situation or if you are using the unstable

      distribution that some required packages have not yet been created

      or been moved out of Incoming.

      The following information may help to resolve the situation:

       

      The following packages have unmet dependencies:

      amdgpu-pro : Depends: libvdpau-amdgpu-pro but it is not going to be installed

                    Depends: clinfo-amdgpu-pro but it is not going to be installed

      amdgpu-pro-dkms : Depends: dkms (>= 1.95) but it is not going to be installed

      amdgpu-pro-lib32 : Depends: libdrm-amdgpu-pro-amdgpu1:i386

                          Depends: libgbm1-amdgpu-pro:i386

                          Depends: libgl1-amdgpu-pro-glx:i386

                          Depends: libgl1-amdgpu-pro-dri:i386

                          Depends: libgles2-amdgpu-pro:i386

                          Depends: vulkan-amdgpu-pro:i386

                          Depends: libvdpau-amdgpu-pro:i386

                          Depends: libopencl1-amdgpu-pro:i386

                          Depends: opencl-amdgpu-pro-icd:i386

      E: Unable to correct problems, you have held broken packages.

      I don't know how to proceed from here, it seems to want to install things like libc6:i386 and that requires libgcc1:i386  but trying to install libgcc1:i386  causes system to ask if I want to replace 100s of packages with i386 versions and says

       

      The following NEW packages will be installed:

        gcc-6-base:i386 libc6:i386 libgcc1:i386

      WARNING: The following essential packages will be removed.

      This should NOT be done unless you know exactly what you are doing!

        apt libapt-pkg5.0 (due to apt) libc6 (due to apt) libgcc1 (due to apt) libstdc++6 (due to apt) init-system-helpers (due to apt) gpgv (due to apt) gnupg2 (due to apt) adduser (due to apt) base-files base-passwd

        libdebconfclient0 (due to base-passwd) bash dash (due to bash) libtinfo5 (due to bash) debianutils (due to bash) bsdutils libsystemd0 (due to bsdutils) coreutils libacl1 (due to coreutils) libattr1 (due to coreutils)

        libselinux1 (due to coreutils) dpkg (due to dash) diffutils libbz2-1.0 (due to dpkg) liblzma5 (due to dpkg) zlib1g (due to dpkg) tar (due to dpkg) e2fsprogs e2fslibs (due to e2fsprogs) libblkid1 (due to e2fsprogs)

        libcomerr2 (due to e2fsprogs) libss2 (due to e2fsprogs) libuuid1 (due to e2fsprogs) util-linux (due to e2fsprogs) findutils grep libpcre3 (due to grep) install-info (due to grep) gzip hostname init systemd-sysv (due to init) libc-bin

        login libaudit1 (due to login) libpam0g (due to login) libpam-runtime (due to login) libpam-modules (due to login) mount libmount1 (due to mount) libsmartcols1 (due to mount) libudev1 (due to mount) ncurses-bin perl-base sed

        libfdisk1 (due to util-linux) libncursesw5 (due to util-linux) sysvinit-utils (due to util-linux)

      0 upgraded, 3 newly installed, 819 to remove and 0 not upgraded.

      Need to get 2 329 kB of archives.

      After this operation, 1 670 MB disk space will be freed.

      You are about to do something potentially harmful.

      To continue type in the phrase 'Yes, do as I say!'

      ?]

       

      Why I am not able to install amdgpu-pro?

       

      Thanks!