0 Replies Latest reply on Feb 26, 2017 3:51 PM by sahandn

    Issue with Drivers after Recent Update

    sahandn

      Graphics Card: AMD RX 480

      Desktop

      OS: Windows 10 64bit

      Driver Version: Radeon Crimson ReLive 17.2.1

      Display: HP 25es

      CPU: AMD FX 8350

      Ram: 8GB

       

      A few hours ago I was prompted about an update for my drivers. I allowed it and chose not to install relive and my computer then restarted. I then played a Maple Story on the highest graphics in windowed mode, which ran perfectly fine, Afterwards I played League of Legends, typically I receive about 200-300 FPS at medium settings, this time around I was getting 10 FPS. After messing around with the settings, no matter what I changed, I would get 10 FPS. This included windowed and full screen mode. I tried Counter Strike: Global Offensive afterwards and it would open to a black screen for about 2-3 seconds and then give me the error code in the attached file. After some research, this error code seems to be associated with your drivers, so I attempted a reinstall.

       

      Currently, both, versions 16.12.2 and 17.2.1 files can be found in :C > AMD > Packages > Apps/Drivers (It's in both). I downloaded the most recent Display Driver Uninstaller and followed the on screen instructions. Something I noticed was that it was not detecting my RX 480 but rather something along the lines of "Windows Display" or something or the sorts. It would complete the process (I tried this step twice) but nothing would come of it. The files previously mentioned would still be there and after attempting to reinstall, again, nothing different was occurring. I am also confused because there are 2 different files on the latest driver download page for the RX series, one labeled "Minimal Setup" and another one that seemed to be the correct one to me (I tried the latter).

       

      The last resort for me was to do a factory reset on my computer. I lack a CD drive but do have a Windows 10 install disk. I navigated myself to the "Reset Your PC" section where I selected "Remove Everything" and it gave me an error that read "Could not find Recovery Environment".

       

      I don't know what else to do, I recently bought this computer after already getting a replacement due to a faulty motherboard. Any help is much appreciated.