8 Replies Latest reply on Feb 19, 2017 1:16 AM by jkoping

    Far cry primal issues HD8500M/HD8700M driver versions 15 and up

    jkoping

      Since the link to amdsurveys.com is broken, and I cannot file an issue report here -> (AMD Issue Reporting Form )  and the page from this (Submitting a AMD Issue Report ) survey does not load

      I'm reporting this issue here. If it's out of place, please be gentle dear moderators, I'm trying to help here but I'm not very educated in the forum's workings.

       

      Describe your system:

      • AMD Graphics Card
        • AMD HD8500M-8700M
      • Desktop or Laptop System
        • Inspiron 15 laptop 3521, windows 8.1
      • Operating System
        • Windows 8.1 64bit
      • Driver version installed
        • 16.150.2111.0 (NOTE: Same issues apply with every driver after 15.3)
      • Display Devices
        • On board screen
        • iiyama screen
      • Motherboard
        • Inspiron 3521
      • CPU/APU
        • Intel Core i5-3337U CPU @ 1.80Ghz
      • Power Supply Unit  Make, Model & Wattage
        • E.g. Thermaltake TR2 700W Gold
      • RAM
        • 6gb

      Describe your issue:

      • Provide a detailed description of the issue you are experiencing and the steps required to reproduce the issue.

      Installing and running Far Cry Primal with drivers later than 15.XX are causing NPC and Animal characters to be visually removed from the game. The game itself runs like a charm, but characters do not seem to load. Since the game is based on working with NPC's and since it's basically a FPS, it's kind of necessary to see who's/what's there and what is not.

      Issue occurs when running the game with the latest driver, and every previous driver back to 15.3.

       

      (Also, issues with Far Cry 4 seem to occur: some areas in the game with heavy shading cause dark blocks to occur. They occur upon loading and cannot be removed. 'Standing' something like 100 feet away, causes all trees and other objects to become the same dark shade if looked in that direction. This is not a gamebreaker as the fore mentioned issue.)

       

      I'm thinking it's Dunia Engine related because of this, since both games are using that engine.

       

      • Details about applications/games affected (including version number)

      Far Cry Primal v1.3

      (Far cry 4 v1.6.0)

      • Graphical settings used in the application/game (resolution and 3D settings)

      No settings applied other than 'standard' AMD settings, no applied profiles.

      Game settings on low, high, ultra all cause the same issue. No matter the resolution, MSAA/FXAA or any other parameter (I've tried it all).

       

      • If possible, include a screenshot or video link of the issue

      Image addition in the forum is broken, cannot upload images.

      Here are some links of what the game looks like with these issues:

      /external-link.jspa?url=http%3A%2F%2Fs1376.photobucket.com%2Fuser%2FJ_Koping%2Fmedia%2FUbisoft%2520Bug%2520Far%2520Cry%2520Primal2017-2-15-19-42-14_zpsarxocuqp.jpg.html%5D%5BIMG%5Dhttp%3A%2F%2Fi1376.photobucket.com%2Falbums%2Fah8%2FJ_Koping%2FUbisoft%2520Bug%2520Far%2520Cry%2520Primal2017-2-15-19-42-14_zpsarxocuqp.jpg%5B%2FIMG%5D%5B%2FURL

      Far%20Cry%20Primal2017-2-15-19-39-43_zpszh1ujsev.jpg

      http://i1376.photobucket.com/albums/ah8/J_Koping/Far%20Cry%20Primal2017-2-15-19-39-43_zpszh1ujsev.jpg

       

      Ubisoft%20Bug%20Far%20Cry%20Primal2017-2-15-19-42-14_zpsarxocuqp.jpghttp://i1376.photobucket.com/albums/ah8/J_Koping/Ubisoft%20Bug%20Far%20Cry%20Primal2017-2-15-19-42-14_zpsarxocuqp.jpg

       

      Any suggestions or help will be much appreciated.

      "Just use driver v15.3?" No, it causes the game to run terribly slow and it renders all my other games useless since they don't run properly. Later drivers work great on any other game, but they cause this issue in this specific game and I'd like it to not do that.

      The game used to run fine, until I updated my drivers. Older drivers make it slow and unplayable, later drivers make it run smooth but visually broken.

        • Re: Far cry primal issues HD8500M/HD8700M driver versions 15 and up
          redfury

          Your GPU is far below the minimum system requirements of this game.

          You must combine low graphics settings with one of the latest driver versions for your GPU. 15.7.1, 15.11.1BETA or 16.2.1 Legacy

          1 of 1 people found this helpful
            • Re: Far cry primal issues HD8500M/HD8700M driver versions 15 and up
              jkoping

              Thank you for your reply,

              With all due respect, I disagree with you though since the game did run well, even on normal settings. High settings caused low fps but everything was visible. Going back to driver 15.3 resolves the issue, but runs at low fps now at terrible quality. Absolutely nothing like before.

               

              Now (with the latest drivers) I'm running high fps even in ultra settings - which shouldn't be possible since my GPU doesn't meet that requirement - but objects and persons are not visible. Even in lowest settings at the lowest resolution, no objects appear.

               

              I will try the drivers you recommended and report back if it works or not.

                • Re: Far cry primal issues HD8500M/HD8700M driver versions 15 and up
                  redfury

                  AMD stopped support for your card before this game was released.

                  You will have no fixes from AMD.

                  If you found a working driver for this game - just use it. Not many people have such luck with unsupported hardware and new games.

                  • Re: Far cry primal issues HD8500M/HD8700M driver versions 15 and up
                    kingfish

                    I don't know why you haven't checked for drivers yourself? The advice you are receiving is not exactly so....and it's certainly not a "correct answer".

                    The latest drivers for your laptop are the 17.2.1 please try installing them after: Mobile

                    1. Windows Update tells you there are NO UPDATES AVAILABLE. If you don't get that message keep installing (critical and optional) updates until that message appears.

                    2. Your Intel graphics have been updated from Intel (follow the guide)

                    3. Laptop graphics update...How to

                      • Re: Far cry primal issues HD8500M/HD8700M driver versions 15 and up
                        jkoping

                        Please see the final post below: it's fixed.

                        Please re-read the first post, because I have been trying nearly every driver after the 15.3 version and only 15.7.1 did seem to work. Current drivers (16.xx and up) cause the issue, that's why I reported it here. I had the time to test 8 or 10 older drivers, but the advice I got after that was to try 15.7.1 and it works. All new and latest drivers have the issue.

                         

                        It seems that AMD stopped support for my GPU, so I'm not expecting a fix in later driver versions. Now I know that 15.7.1 works, and I have it backed up, I can always check if newer versions have a fix, but the versions available right now, don't.

                         

                        The problem is resolved when I use the 15.7.1 driver version. For now, that's good enough for me. I just want to stop troubleshooting and start playing. With an average install and testing of 1 driver per 30 minutes, I'm kind of mentally done with my 3 days of routinely installing+testing+deleting the entire afternoon. I have my fix.

                         

                        As for the windows update: the optional driver update it pushes, disables my AMD card completely, causing it not to work. BSOD's, crashes, then it kicks out the card completely while losing all driver info (No AMD product found, unable to install software and drivers. AMD Radeon settings has stopped working. Etc. etc.) and it makes my screen look like the HDMI cable is leaking power, with flickering pixels everywhere.

                        All other windows updates are done weekly. Intel has been updated with the update manager. Of course, I did this at the start of my entire troubleshoot quest, since that's where the issues usually come from. It did not help.

                         

                        Here's a crash log from the 16.2 drivers I tried last thursday or wednesday:

                        Naam van de toepassing: FCPrimal.exe

                        Versie van toepassing: 1.0.0.0

                        Tijdstempel van toepassing: 57d93bd3

                        Naam van foutmodule: aticfx64.dll

                        Versie van foutmodule: 8.17.10.1474

                        Tijdstempel van foutmodule: 57ac36b0

                        Uitzonderingscode: c0000005

                        Uitzonderingsmarge: 000000000005c39e

                        Versie van besturingssysteem: 6.3.9600.2.0.0.768.101

                        Landinstelling-id: 1043

                        Aanvullende informatie 1: 3d55

                        Aanvullende informatie 2: 3d5531f59c83029ae7bcc5c9d79dced6

                        Aanvullende informatie 3: 3357

                        Aanvullende informatie 4: 3357ca5b8b62b015c0caa9c5abd1460d

                        I contacted Ubisoft, over there people seem to be having the same problems as well with versions after 15.7.1, even with cards that should handle the game just fine. So it seems AMD driver specific in this case.

                         

                        If you have another suggestion, something I didn't try already, please feel free to inform me. I would feel better with using later driver versions, since other games run better with those, but FC primal just crashes or "forgets" to load characters with the latest driver versions.

                        1 of 1 people found this helpful
                  • Re: Far cry primal issues HD8500M/HD8700M driver versions 15 and up
                    kingfish

                    Windows 8.1 must be fully updated before any attempt to install any AMD driver. Goto Windows Update and run it. Unless it tells you  "there are no more updates"  keep installing them (critical & optional) until you get that message.

                    Then install the correct driver suite > http://support.amd.com/en-us/download/mobile?os=Windows%208.1%20-%2064  either the 17.2.1 or full version 16.12.2.

                    Install them following this guide > Laptop graphics update...How to  for Intel/AMD graphics....after updating the Intel graphics.

                    • Re: Far cry primal issues HD8500M/HD8700M driver versions 15 and up
                      jkoping

                      Issue was resolved after installing the 15.7.1 drivers and corresponding catalyst control center.

                      After tweaking some settings, the game runs like a charm again. High fps at a little below lowest settings.

                       

                      Now, for the people having the same issue:

                      Step 1: Download the file called amd-catalyst-15.7.1-with-dotnet45-win8.1-64bit.exe. You can find it here: Legacy

                      Step 2: Download the AMD cleanup utility and run it as admin

                      Step 3. Wait for cleanup utility to finish

                      Step 4: Restart, run something to clean registries like Ccleaner.

                      Step 5: Install the 15.7.1 driver version

                      Step 6: Run game, tweak settings to your liking.

                      (Optional: if you're running on a laptop, make sure both Intel drivers and windows are up to date, it seems to help when it comes to framerates and communication between switchable graphics).

                       

                      Thanks again community! The issue is resolved/fixed.

                      redfury, if it wasn't for you, I would still be troubleshooting. Thank you in particular!

                      1 of 1 people found this helpful