AnsweredAssumed Answered

XFX RX 480 Black (1388 Mhz) artifacts

Question asked by gbihtas on Feb 17, 2017
Latest reply on Feb 18, 2017 by kingfish

Hi,

I have received my brand new xfx RX 480 (gtr black OC 1388Mhz).

 

My system is the following.

 

CPU: i7 920 overclocked @ 3.6

GPU: nvidia gtx 295, gtx 610, rx 480

Motherboard: EX58-Extreme

RAM: 12gb DDR3 triple channel

Monitor: 1900 x 1200

PSU: 1200W THERMALTAKE Toughpower

OS: Windows 10 - 64 (I also run Linux but it is irrelevant for this thread)

 

This is the first AMD gpu for me. So, as soon as I received it, I removed my old GPU and plugged in the RX 480. The system booted normally. I logged in and everything seemed OK apart from the fact that my system was running on lower analysis (which was anticipated). I downloaded the latest drivers, 17.2.1 and installed them.

 

As soon as the installation of the drivers completed (and before prompted to restart my system), my screen breaks, blinks, black screens, snow, aritfacts etc. I cannot even see where the mouse cursor is. The desktop appears only 1 second and then for the next 10 seconds my screen is a mess. The only thing I can do afterwards is hard reset and plug in another card. If I did't have an older gpu my system would be useless. Both my nvidia cards work just fine so no hardware problem (e.g. mobo, PSU etc)

 

Mobo has the latest stable BIOS (F12)

 

- Tried a number of drivers, the ones provided with the CD, from the website etc.

- Uninstalled all drivers (nvidia, amd) using DDU and then fresh install in safe mode.

- Amazon sent me a second card. The same issues.

 

My system has both Linux and Windows. I use Linux for development etc. and Windows for games. Even when I am prompted from GRUB to select OS, I see a few blue lines. If I load Linux the same. Artifacts on screen.

 

Totally dead end. Is AMD drivers so bad for my system? Is it the specific XFX model? Is it the RX 480 series? Don't know what to do. Buy an RX 480 from Sapphire for example or move back to Nvidia (eg gtx 1060)? I was so optimistic to move to AMD's 480 but my experience so far is really terrible.

 

If that helps, I have raised an issue here as well: http://www.tomshardware.co.uk/answers/id-3333020/faulty-gpu-xfx-480-black-1388-mhz.html#19305282

 

 

Thanks,

 

 

George

Outcomes