32 Replies Latest reply on May 28, 2018 8:52 AM by deepmindedsq123@gmail.com

    16.12.2 and 17.2.1 drivers won't install, error 1603

    tmach

      I have been trying for several days to install drivers for an R9 380x with no luck. The installer always finishes with "driver not installed. error 1603", and upon reboot (and attempted reinstallation) it reports "partially installed". 

       

      Allowing windows to install it's version of the Radeon drivers first at least allowed Radeon Settings to install (before, even that would not work) but not all of the functions work.  For example, it will not scan for games, ReLive is not intstalled and software updates do not work.

       

      The only error I see in the log is this:  error in SetCfgFile::[16-02-2017 01:17:10]  IMConfig file = >C:\AMD\Non-WHQL-Win10-64Bit-Radeon-Software-Crimson-ReLive-17.2.1-Feb10\Config\InstallManager.cfg<

      (Copied that after trying 17.2.1 drivers.  Admittedly did not check to see if the same error was present after the failed 16.12.2 installation)  I can attach the entire log if necessary.

       

      I have tried choosing "clean installation", using AMD's clean uninstall utility, DDU (in save mode) and scanning the registry for any errors (none found) and registry repair (tried anyway, even though no errors were found).  Nothing has worked.  Unfortunately, I don't have a restore point I can use and REALLY don't want to do a fresh windows install.

       

      System specs:

       

      i7-5820K

      32mb RAM

      ASRock Fatal1ty x99

      XFX R9380x  4mb

      Windows 10 64-bit

      OS installed on Intel 256gb m.2 (ssd6)

       

      Any help is greatly appreciated!  Thanks!