AnsweredAssumed Answered

Sapphire RX460 "Display driver stopped responding and has recovered"

Question asked by l2579930 on Feb 14, 2017
Latest reply on Feb 17, 2017 by arcticwind

Hello, I recently bought a sapphire rx460 to upgrade an old system that was basically a G31M-S, E5400, 2x 2gb ddr and a regular gener psu. After installing it I had some trouble with the image, I'd see something like this:

niIpsOT.jpg

Tried in both my tvs and I saw the same thing, asked a friend to borrow their system, somewhat similar e7400, 2x2gb ddr2 and can't remember exactly the model of the mobo but it was an asus. So, I install it there, boot up the pc with the same drive I had from the other pc and I see something like this on the mobo screen, but it keeps going and once it reaches win10 it's actually fine, I can finally see. I install the basics like directx, drivers and some programs and run league, start a custom match to see if everything works fine, after a while my tv sort of resets and shows me the resolution as if I was just selecting the HDMI source for the first time, also the game is "minimized", by this I mean that I can't see the game, instead I see everything I had in the background but I'm still stuck with the lol in-game cursor and I can't click on anything. Fast forward a couple days, in my mind this could be a driver problem somehow, since I installed windows with another mobo maybe something is different and that's the problem (trying to be optimistic) I try to restore windows, it forks up leaving me without any O.S. the mobo doesn't have the option to boot via usb drive, I buy some DVDs, burn win10, install windows, the basics, still the same, when the game minimizes and leaves me looking at the background I can see a small yellow alert sign next to the clock, I quickly close the game and I read the message "Display driver stopped responding and has recovered". I google for an answer, find multiple posts, I try these solutions none of them work, so far I've tried:

-Updating the driver

-Checking for multiple simoultaneous drivers

-Reinstalling directx

-Increasing GPU's processing time

-Reinstalling windows

-Changing the PSU

-Checking temperatures, even under stress

 

The only two things that I can think of right now are, either it's a defective card or maybe since it has a factory overclock that's somehow forking things up? Basically I'm afraid that I'll pay for shipping for the RMA and when they "test" it they simply come up with "I see just fine", since after all, the problem that I told them about came up with my own pc, on this one it works fine other than mobo screen and games.

This is the link to the card: SAPPHIRE Technology

Outcomes