7 Replies Latest reply on Feb 14, 2017 9:39 AM by jumpsuit

    AMD Drivers needed

    jumpsuit

      Well I have a situation I need resolved easily. My ATI Radeon HD 4600 series graphics card won't load any Java based games and getting a "org.lwjgl.LWJGLException: Pixel format not accelerated" error. Now, I know this either means update drivers or its just obsolete. But I am leaning towards driver outdated but for whatever reason, Windows 10 doesn't consider older AMD graphics cards such as mine to not work, and I can't just downgrade windows version as I have no easy way of doing so. And fixes that may resolves this AMD - Windows 10 issue?

        • Re: AMD Drivers needed
          kingfish

          You have to use the drivers furnished by Microsoft:

          Windows® 10 Driver Support for Discrete AMD Radeon™ Graphics Products

           

          The following Discrete AMD Radeon™ Graphics products support up to WDDM 1.1 and DirectX® 10.1:

          • ATI Radeon™ HD 4000 Series /ATI Mobility Radeon™ HD 4000 Series Graphics
          • ATI Radeon™ HD 3000 Series /ATI Mobility Radeon™ HD 3000 Series Graphics
          • ATI Radeon™ HD 2000 Series /ATI Mobility Radeon™ HD 2000 Series Graphics

           

          These graphics products must be installed using display driver version: 8.970.100.9001. This driver is provided as a courtesy and only available via Windows Update. Please enable Windows Update and allow it to detect and install the appropriate driver.

           

          NOTE: ATI Radeon™ HD 4000/ATI Mobility Radeon™ HD 4000, ATI Radeon™ HD 3000/ATI Mobility Radeon™ HD 3000, and ATI Radeon™ HD 2000/ATI Mobility Radeon™ HD 2000 Series Graphics reached peak performance optimization on October, 2013. No additional driver releases are planned for these products.

          1 of 1 people found this helpful
            • Re: AMD Drivers needed
              jumpsuit

              Well heres what I got right now, but as you can see it is correct, but even with that driver, Java still won't load anything.

              1 of 1 people found this helpful
                • Re: AMD Drivers needed
                  kingfish

                  Why do you think AMD graphics has anything to do with Java? Have you downloaded Java? Updated Java? What browser is set as your default browser? Does it allow Java?

                    • Re: AMD Drivers needed
                      jumpsuit

                      Well, I think this because java based games such as Minecraft and Starmade both get that error according to the crash logs, my browser i ain't worried about as adobe is the most used across the web. But for some reason my AMD/ATI drivers don't function properly is what it appears to me as or not fully compatible with Windows 10.

                        • Re: AMD Drivers needed
                          ray_m

                          Your product is too old and has been moved to legacy status. That means there are no drivers available for it from AMD. You will need to rely on Microsoft for limited driver support via Windows Update.

                            • Re: AMD Drivers needed
                              jumpsuit

                              Well I bring good News, I have resolved the problem. What was happening was (what in theory was wrong when i realized it) the on-board VGA graphics were outdated, thus making Win-10 use the basic display adapter instead of the Graphics Card and also considering my monitor a Generic Non-Php monitor. but when i went to buy a DVI-I cable to try and use as alternative graphics solution, as my card has 2 dvi-d females ports and 1 s/pdif female port. so i linked that to my monitor (supports both VGA and DVI-D) and booted my pc up and it worked like it was supposed to.

                            • Re: AMD Drivers needed
                              kingfish

                              An example would be the Win10 only "Edge" browser which does not support a Java plugin and won't run a Java program.