24 Replies Latest reply on Mar 17, 2017 12:24 PM by eternitynetwork

    Radeon RX470 Glitching/Crashing - Drivers having problems

    eternitynetwork

      I recently bought and installed an RX470 on my PC (brand new build - specs below). After 2 weeks of having built the PC, while I was browsing, the PC crashed and restarted, with glitches on the Monitor. I wasn't able to also get into Windows without using Safe Mode. After searching for the problem, I uninstalled all the drivers and reinstalled them again. Everything went ok, the glitches were off.

       

      Next Day, the same thing happened. That time, I decided to go back to a System Restore Point which worked for me.

       

      After 1 or 2 days,it happened again. I tried the Restore Point but it didn't work. Then, I tried to reinstall the Drivers but whatever driver I tried installing (I tried many) it would not finish installing (it would crash and just put me in a black screen, without the PC shutting down). I disconnected the Card from my PC in order to use my integrated Intel one, since I had to work. The next day, I tried to fix it and after 5 or 6 times of me installing and uninstalling Drivers I got it to work, without knowing how. The only thing I know is that the Driver that I installed was (maybe) the latest Driver, which I had seen for the first time through these days (it had a Red Background)

       

      This is the installer that I usually used, NOT the one that worked for me on the last time.

      Screenshot_2.png

       

      Today, I started my PC up and the glitches appeared again (yesterday, when I shut it down, everything was fine). I tried everything but it didn't work. When I tried installing the drivers again, it kept crashing like it did last time.

       

      *What I noticed is that, although I only have the "Radeon-Crimson-ReLive-17.1.2-MinimalSetup-170208_web" setup installed, in my C:\AMD folder, when I start the setup, it also creates a "radeon-crimson-relive-16.12.2-minimalsetup-170106_64bit" folder, which means that is probably installing the 16.12.2 and not the 17.1.2 which it should*

       

      What could I do? At the moment I am really fed up with the whole situation and probably can't think clear on what the problem is.

       

      Picture of me trying to access Safe Mode to fix it (The Glitches):

      Screenshot_1.png

       

      System Specs

      Graphic Card: AMD RX 470 Sapphire

      Display Device: Dell LED 24" S2415H
      Motherboard: MSI B150M Mortar Arctic
      CPU: i7 6700K @4.00GhZ

      Power Supply Unit: Corsair CS550m

      RAM: 16GB

      OS: Windows 10 Pro 64bit