4 Replies Latest reply on Feb 12, 2017 5:01 AM by eternitynetwork

    RX480 not working. Can't Install Drivers Correctly. When I force the PC to load up using the RX 480 the screen appears fragmented. More in Post

    natsprat

      GPU: Power Color Red Devil RX 480 8gb

      Motherboard: Asus B250 Plus

      CPU: Intel Core i5-7500

      OS: Windows 10 64bit

      PSU: Corsair 500W

      RAM: 16gb

       

      Recently made a new build. Everything works apart from GPU. It has an error code of 43 in Device Manager. When I attempt to install a driver on the GPU it will not let me.

      I have re-installed my OS.

      Tried Windows 7.

      Used DDU to delete all drivers and manually install the drivers.

      Changed BIOS primary adapter to GPU and when computer boots up the screen is fragmented like so http://imgur.com/V8RrGIF

      Re-seated the GPU a few times.
      Weirdly I have noticed that the GPU sometimes does not have an error in Safe Mode.When using the Installer. I get this error log at the end. Error — Postimage.org

      When I have opened GPU-Z to see if my card is recognised at all I get these - http://gpuz.techpowerup.com/17/02/08/gqw.png  and http://gpuz.techpowerup.com/17/02/08/8yy.png

      I have downloaded games and tried to run them and I just end up getting errors.

      I have tried everything I have found on the internet and have spent over 20 hours trying to fix this issue. I am starting to think the card is just broken.


      Any help is deeply appreciated, thank you.

       

      Message was edited by: Nathan Lee Edited