1 Reply Latest reply on Feb 13, 2017 6:09 AM by amdmatt

    AMD Radeon HD 6800 not to be found in Device Manager?

    lawsker

      I just used the amd cleanup utility in order go get rid of my drivers since I wanted to clean up my boot drive.

      Everything worked fine, except for when I restarted the PC, my HD 6800 was not in use. Of course, I tried to install the newest drivers that are available (I know, my GPU is old but nah) and tried to install them. I manually selected the drivers I would need at the AMD download site.

      I installed them, but after I did so, it would not be used. I could also not find it in the device manager itself, instead it says that I am using a standard vga graphics card.

       

      My final question: what should I do? I already know that my graphics card is properly plugged in and such..

      As I am quite desperate right now, I hope to find a good and quick solution

       

      Specs: (I know, I should upgrade )

       

      AMD Athlon X II 270 Processor

      AMD Radeon HD 6800 GPU