4 Replies Latest reply on Feb 7, 2017 9:19 AM by ronniedude

    Computer Powers Off (As if unplugged) randomly when playing overwatch with newly installed RX 470.

    ronniedude

      Computer Type: Desktop

       

       

      GPU: 1x ROG STRIX-RX470-4G-GAMING (Factory Stock Clocks)

       

       

      CPU: AMD FX-6350 @ 4.0GHz (see description)

       

       

      Motherboard: GIGABYTE|GA-970A-UD3P AM3+

       

       

      RAM: Mixed Ram, 12GB, no overclock

       

       

      PSU: Antec C NeoECO 620W ATX12V 80 PLUS BRONZE Certified

       

       

      Operating System & Version: Windows 7 SP1

       

       

      GPU Drivers: Radeon Software Version 17.1.2

       

       

      Background Applications: Overwatch, EVE online, chrome, discord, steam, mumble, slack, battle.net launcher, eve launcher, logitech mouse drivers, audio drivers, radeon drivers.

       

       

      Description of Problem: I also don't know if this is 100% restricted to overwatch, it just happens to be the game i play the most so it could be coincidence it happened both times while playing it. I had a GTX 670 (for years everything was stable) and after installing my 470, I was a few rounds into overwatch, then the computer just blacked out, as if it was unplugged. I thought it might be because my CPU overclock, so I lowered it from 4.4ghz to 4.0 on my FX 6350. But then it happened again two days later during overwatch.

       

       

      Troubleshooting: Again, I thought it might be because my CPU overclock, so I lowered it from 4.4ghz to 4.0 on my FX 6350. I've tried to recreate the problem with no results, running both games together and disabling any fps cap as well to make sure the card is going full throttle too. I've even tried lowering the fan settings to see if I could recreate an overheat scenario.

       

       

      ---

       

       

      Should I return it (< 30 days still), RMA, or possibly upgrade my Mobo/power supply (current one is 620W)?