1 Reply Latest reply on Feb 4, 2017 7:22 PM by xeleron

    rx 480 not detected, error 173, no video output

    furiouszombie

      Hi, I have a Sapphire RX 480 Nitro+ 8gb. After installing the card in my PC I had no video output, Sapphire logo lights up but fans do not spin. When I switched the hdmi cable to the integrated graphics I could see that no AMD hardware was detected in device manager. I used the amd clean uninstall tool (previously had a 4gb sapphire r9 380 OC) then tried installing drivers for the 480 from the AMD website.

       

      The AMD software would not install any drivers, it just displayed error 173 (no amd hardware detected).

       

      I updated my BIOS and tried again, same error.

       

      I then tried uninstalling any previous drivers using DDU and restarted in safe mode. Attempted to install amd drivers, error 173.

       

      Someone suggested I try using the disc that came with the card to install drivers, so back to DDU, then ran the disc install, it installs some catalyst manager software but then immediately finishes the install within about 5 seconds, no driver was installed. Then tried latest catalyst drivers, different error saying the card was not compatible with this version of the drivers (They are definitely the correct drivers for the card).

       

      I've repeated these steps on another pc, same issues. My main concern is that all the posts about the same issue I've seen online all describe the fans as spinning up when they install the card. Mine doesn't. I've tested the PCI slot, no issues. The card is not detected by any system info software I've tried.

       

      I'm pretty much out of ideas at this point, it seems like this is a dead card to me, am I right?

       

      PC specs:

      CPU: i7 4770

      MOBO: ASUS H81m-plus

      RAM: 8GB Corsair Vengeance 1600Mhz

      GPU: Sapphire RX 480 Nitro+

      PSU: 650W Corsair VS 650

      SSD: 250gb Samsung 840 EVO

      HDD: 1tb Seagate Barracuda

      OS: Win 10 home x64