7 Replies Latest reply on May 6, 2017 7:43 PM by vortex13

    R9 390 Crossfire ULPS Problems

    vortex13

      I am having an issue with the slave GPU in crossfire getting stuck in PCI Gen 1 speeds when ULPS is disabled.   This happens to whatever the slave card is set to, top or bottom.  Slave card will always get stuck at core clock 300mhz core clock and 150mhz memory clock, while masters clocks increase. This results in massive stuttering(fluctuations between 15-30FPS) and games being unplayable. The strange thing is crossfire works normally when ULPS is enabled and both cards will reach their max clock speeds. Does anyone have any idea on what the issue is? I saw something similar in the following thread, however I have had the issue on previous driver versions as well.

      ☠☠☠☠ PSA - Crossfire Users - Do not upgrade to 16.12.1 ReLive Edition ☠☠☠☠

       

      I have tried the following with no success:

      • Different driver versions, currently on 17.1.1
      • Clean install of Windows 10
      • Disabling using software such as MSI Afterburner and Sapphire TriXX
      • Disabling ULPS manually in the Registry
      • Power efficiency is disabled in Radeon Settings

       

      The strange thing is the GPU with no inputs connected will show up as grayed out in the wattman charts, I have posted a picture below.  This also occurs with crossfire disabled unless i connect something to the 2nd GPU.  Could this be some kind of power saving feature in the R9 390 BIOS when nothing is connected?

       

      System Specs:

      MSI Z170 Gaming M5

      Intel Core i7 6700k (Stock Speeds)

      Corsair Vengeance 2x 8GB 2666mhz DDR4

      2x MSI R9 390 Twin Frozr

      Corsair RM850x

      GPU2.png

      What it should look like:

      GPU1.png

        • Re: R9 390 Crossfire ULPS Problems
          kingfish

          Your Power Limit should be set to +50. AMD graphics performance

          Disable ULPS in the registry....not by some third party app. ULPS: How to disable

          Screenshot_11.png

            • Re: R9 390 Crossfire ULPS Problems
              vortex13

              Hi, Thanks for the advice however setting the power limit to 50% for the cards did not resolve it.  Slave GPU still never goes above base clocks when ULPS is disabled.  Also, I have not used the third party tools since I did the clean install, that was previously on the old windows install.  I've disabled it directly in the registry.  Any other ideas? You can see below the chart is still grayed out and the green and orange lines representing the clocks never increase, even though the blue line(GPU usage) increased.

              GPU3.png

              Disabled in both 0000 and 0001

              ULPS.PNG

            • Re: R9 390 Crossfire ULPS Problems
              savagebeastzero

              Hey vortex13,

               

              Firstly I'd like to apologize for my lack of free time to devote to the support forums in recent weeks, thus never having the time to publish my findings in regards to my initial thread ☠☠☠☠ PSA - Crossfire Users - Do not upgrade to 16.12.1 ReLive Edition ☠☠☠☠. After conducting my troubleshooting measures shortly after creating that thread I discovered multiple causes which were eliciting this behavior as described.

               

              Although my time at the moment is limited, I promise to publish my findings by the upcoming weekend to bring clarity to the situation being experienced by Crossfire users. I'll also ensure to touch on anything else I believe you might believe to be of interest being as thorough as possible, so everything can finally come full circle in regards to this subject.

               

              I will elaborate that certain aspects of the cause are out of our hands and a definitive solution might not be on the near horizon.To bring clarity now to this "conflict", would take me more time than I currently have available. Yet, regardless I'll explain everything I've discovered since the inception of that initial thread and ensure I answer the questions you have above as well.

               

              So, once again I apologize for not completing the work I began which would have brought some clarity to the community, but I promise this will most assuredly come shortly, albeit I won't necessarily be bearing information that Crossfire users, nor enthusiast overclockers will necessarily be pleased to hear for the time being. Either way, I'll try to bring this data to a close as soon as possible and next time I begin a thread, I'll double check my schedule to ensure I can complete the work I begin or I'll refrain from posting it until I can provide support to the end user.

               

              Furthermore, for the time being, I am recommending you not follow the guidance provided by support forum user redfury  above, because the troubleshooting procedure being recommended by him is unnecessary, incorrect and in no way correlates to your situation you are experiencing. It will only ensure you are multiple steps backwards, causing further unnecessary frustrations and that's not what we're here to provide to the AMD community.

               

              Thank you for your patience and have a nice day.

              1 of 1 people found this helpful
              • Re: R9 390 Crossfire ULPS Problems
                vortex13

                I would like to add that I now have the issue of the slave GPU clocks getting stuck constantly now when using drivers 17.4.1 and later.  It doesn't matter if ULPS is enabled or disabled.  Drivers 17.5.1 have not rectified the issue a month after the problem popped up.  I have reinstalled windows 10 multiple times, both the creators update the the previous version but the issue persists.  This is very disappointing as it shows AMD's lack of support for older cards....