1 Reply Latest reply on Feb 1, 2017 9:04 AM by amdmatt

    RX470 random black screen while gaming

    gabcenz91

      Hey guys, I'm new in the forum. I'm glad to find this place, looks very organized and with plenty of support.

      Now, my case, I recently bought an AMD RX470, it's and Asus Strix Oc 4GB. Ok I installed Crimson 16.12.2 drivers and I was surprised with the card, it was very silent and I was getting high fps on my games at 1080P, maxed out. Mostly I'm only playing BF3, BF4, L4D2 , and The Crew.

       

      The thing is that I'm experiencing some ramdom black screens while playing, it happened yesterday after 5 minutes while playing BF3. And I got the "no video signal" on my monitor.

      The other day it happened again while playing The Crew, but this time it happened after 3 hours. The same case, black screen, couldn't do nothing, only force the pc to restart.

      Temps are fine, although in Peru it's summer.  M  y RX470 temps never go above 68° and my CPU is below 54° at full load or gaming.

      I might try the latest beta drivers 17.1.1, would you suggest me to do it? I've seen some posts here, of users experiencing some issues with this drivers.

      By the way I have the card at stock settings.

       

      My pc specs are:

      Intel Core i5 750 @3.2Ghz

      8GB DDR3 1600

      Asus Sabertooth 55i (Bios2003)

      Asus Strix RX470OC

      Corsair TX650 PSU

      Windows 7 64 bit Service pack 1

       

       

      Hope you can help me with this issue, thanks in advance!  I'll keep testing to see how it goes. Oh and sorry if my english is not very very good, but I did my best, hehe.

       

      Gabriel