12 Replies Latest reply on Jan 28, 2017 12:17 PM by ifixit

    AMD A10-7860k quad only 2 threads working. Half CPU alseep.

    ifixit

      Why are 2 cores/threads of my A10-7860k at 14x and the other two at 36x.?

       

      hwinfo64 latest version beta, report, under stress CPU-z 4 threads..2 cores at idle 14x 2 at 36x

       

      msconfig/advanced, nothing ticked for processors.. Device manager shows 4 cores

       

      GPU R9-280x pcie-3 8x not 16 never shifts regardless generation.

       

      GB MB GA-F2A88xm-HD3P bios F2 supports CPU according to GB website../ is latest bios. supports CPU.

       

      Was functioning ok until CPU change..properly..changed CPU back too A8-6600k it's not only working 2 cores. Fresh win 10 home x64.. all updates all drivers latest.

       

      have unparked cores, rerun util says unparked, still problem persists.

        • Re: AMD A10-7860k quad only 2 threads working. Half CPU alseep.
          ifixit

          Fresh install. RS1 1607 updates, all amd drivers latest.

           

          Rest bios, hmm. now normally you just use a jumper, I did, only resets cpu settings.. did not reset bios. Reset bios, this time pull power cable, pulled battery, left jumper on for 20 secs.

           

          Started PC.. says reset, but raid was still there and all my settings..WTF?

           

          GA-F2A88XM-HD3P MB manual just says to jumper above USB Front port..i did that.. and more..

           

          This is crazy..AMD.

           

          I've been remoted by Microsoft teir one, they have a research engineer phoning me tomorrow morning..they looked at the isses did a few things put me on hold while she talked to the teir one overseer, it's THAT crazy.. Check out my hwinfo dump.. what is going on AMD.?

          • Re: AMD A10-7860k quad only 2 threads working. Half CPU alseep.
            ifixit

            PS, replacing motherboard means changing whole system, going from an A8-6600k to an A10-7860k isn't THAT much in comparison. IMHO. When the CPU's GPU is disabled due to a dedicated GPU.

              • Re: AMD A10-7860k quad only 2 threads working. Half CPU alseep.
                ifixit

                I'm a 40 year pc engineer who's been tech manager and senior engineer of NZ's largest in their day PC manufacturer with over 100,000 PC's in NZ, in a population of 4 mil I think I know a few tricks..I've attended many MS seminars, Intel road maps and AMD's ones, knew MSI Asus and Gigabyte tech support directly and often they came to visit as we were a legit Microsoft, Intel, MSI and AMD OEM partner.  , however i'm not so cocky to think I know it all. I did a little more than read the manual.... seeing the manual doesn't tell you you have to FULLY depower the bios to reset, it refers to a jumper above Front USB.

                 

                Thanks for your tips, I didn't obviously get the cmos cleared, I have now.. ten minutes with battery and all power connectors off board, reset jumper, did the trick.

                 

                reset up bios, raid the lot prior to booting

                Issue persists.. i'll actually take the common stuff in case I missed something or are having a senior moment..., just stressing mate, I've installed over the years tens of thousands of cpu's hell 100,000s never ever seen a faulty CPU, once we did RMA one once, for funnies going on but we swapped out MB HDD and PSU on that particular one as we could not narrow the issue down on a clean install of XP at that time, and problem disappeared.., but that still isn't conclusive.

                 

                I've been out of the industry ten years, hence bit shady on the news stuffg, but the 40 years of IT knowledge is still there, just maybe missing some modern issue resolving tips.

                • Re: AMD A10-7860k quad only 2 threads working. Half CPU alseep.
                  ifixit

                  Thanks, systems rather stable, so I am agreeing here.. hence wanting a tech at AMD to look at my PCI registers for a disabled system device holding it down..

                   

                  You know stuff too, can we get to the technical side of things..i did solve ALI's stuttering video playback on the ALI16?? 01 god going back a bit.. but I got a M<SDN mention for that,,, I have some medicore skills, I just don't have teir 3-4 skills and know the registers of new hardware, or all the old for that matter and what they relate too, only amd know that stuff. really..there are some clever chaps about though.

                   

                  This issue has all the sign of a cpu bug, seriously..

                   

                  what i'm trying to say is I have a workshop and Good IT skills I can handle anything any high level tech wants me too. anything..within reason.

                  • Re: AMD A10-7860k quad only 2 threads working. Half CPU alseep.
                    ifixit

                    Let me make an image to back up..

                     

                    I'll do that, it's common sence and your spot on.. I reset I haven't reinstalled after..

                     

                    Need to get it down to basics, totally agree good Diagnostic practise.. i'll be back in an hour or so with a report on that.. I will clear cmos again resetup bios, then install from the usb install tool so it's fresh, update os, update drivers..think that was the pattern been awhile since I got down to diagnosing..

                     

                    thanks mate. sorry if I came across grumpy, i'm not, just been a long day. more stress than grump

                      • Re: AMD A10-7860k quad only 2 threads working. Half CPU alseep.
                        ifixit

                        LOL.. your going where I came from, when I changed over cpu and went to test it with some benches for stability, I found my PCIE was running at 1-1 8x gen 2 8x Gen 3 8x it would go up under GPU load from 1-1, (it'll throttle the PCIe bus down when no traffic is present.) That's my original fault, it was diagnosing that, that I found my new CPU was only half working..i guessed if the CPU isn't running 4 cores, or is maybe faulty(Highly unlikely), i'd better start there.., the speed negotiation by the PCI bus is tested if it cannot negation 16 lanes it will ramp down, but it should do Gen 2 at 16x as with the A8-6600k it ran on that(Gen 2 x16. For it never to change the lanes from 8.. had me thinking CPU.. I need, I think to iron out the CPU issue before I focus on the PCIe bus speed issue as it will likely disappear if I solve the former

                         

                        ? what do you think?.

                         

                        Ubuntu live drive.. Linux/unix.. I aint so hot on that os.. you would call me a learner driver. But I have dabbled and played with it, beos etc so lets have a look at that first... will get back.

                        • Re: AMD A10-7860k quad only 2 threads working. Half CPU alseep.
                          ifixit

                          GIGABYTE emailed and gave me a yet to be released bios, version F3a for that Motherboard, my cores are alive!!!

                           

                          My PCIe bus is another story..

                           

                          Edit NOOOOOOOO

                           

                          check this out folks

                           

                           

                          So after getting there bios update I went into bios and did the following

                           

                          SO if you technically enter the bios and do this..

                           

                           

                          Set the cpu ratio to a set multiplier say 40

                          Disable core performance boost

                          Disable turbo performance boost

                          Disable core performance boost ratio

                           

                          Here we fixed the cpu to a set frequency to stop it ramping up and down all the time. Or boosting way above what we find is the maximum stable cpu speed

                           

                          Disable AMD cool&quiet

                          Disable cTDP function

                          Disable SVM Mode

                          Disable C6 mode

                          Disable APM

                           

                          This stops the system entering sleep states on the CPU.

                           

                           

                          You get

                           

                          2 working cores

                          2 sleeping cores

                           

                           

                          Go back in bios

                           

                          Set them all back to default or enabled,

                           

                          All 4 cores functioning in windows 10 x64.

                           

                          None of those changes fix the PCI-e bus, ALSo that’s a bad BUG!!@!

                           

                          Those are really only for power misers, energy saving people, NON gamers, NON performance users. That’s what they are for.. not to be stuck like this, wow.

                           

                          They must be getting interested up there at the IT gods workplace by now.

                           

                           

                           

                           

                           

                          fixedcoreafterbiosupdate.jpg

                           

                           

                          hairpullingnightmarecpufromhell.jpg

                            • Re: AMD A10-7860k quad only 2 threads working. Half CPU alseep.
                              ifixit

                              OK we are down to this..with AMD cool n Quiet DISABLED!!!! WHY does 2 cores go into sleep state. Yet ENABLE this one setting all 4 cores function!! This is the REVERSE of what SHOULD logically happen.

                               

                              The PCIe bus is reporting now 8.0GT/s 8x the 8x is a misread..8.0GT's is gen 3 16x.. solved..

                               

                              Cores degrading not solved.

                                • Re: AMD A10-7860k quad only 2 threads working. Half CPU alseep.
                                  ifixit

                                  and..new issue sata in bios setting I have 2 240gb ssd's set up as raid in bios. I have a 1tb wd storage drive and a sata dvd writer, on sata ports 4 and 7 ..

                                   

                                  all come up in the raid no matter what.

                                   

                                  So also the sata feature setting isn't working for ports 4-7.

                                   

                                  does anyone out there have a Valium.

                                  • Re: AMD A10-7860k quad only 2 threads working. Half CPU alseep.
                                    xeleron

                                    Have you benchmarked the system and noticed that the 4 cores are not performing well?I ask this because HWinfo has only PARTIAL overclock detection,and I had the same problem that you do with it,on an overclocked q6600 which is not capable of shutting down cores or reducing the fequency only for one of them.

                                      • Re: AMD A10-7860k quad only 2 threads working. Half CPU alseep.
                                        ifixit

                                        Hi Xeleron thanks for the feedback, yes checked that out early, benching in multiple utils hwinfo cupid cpu-z were way down in performance and you could tell by responsiveness etc, it was running like an old Fx-60.once they gave me the bios update and I found I could get 4 cores working with C&Q enabled re benched scored damn straight results for 4ghz vs 7650k about a 1-3% above. Before on 2 that results was 25% lower than the 7650k..

                                         

                                        Definitely 2 cores being shut down.

                                         

                                        Thanks though i'm taking any idea's or someone from AMD pulling finger and realizing if that cpu don't work properly and is bugged, they have a big problem on their hands, internationally and I don't bandy about hyperbole...,lets hope it's motherboard compatability eh.

                              • Re: AMD A10-7860k quad only 2 threads working. Half CPU alseep.
                                ifixit

                                Thanks for getting back Janagewen,

                                 

                                Grasping at straws but I like your thinking, yes I know the function, I have tried all variations of that setting, currently it's set to disabled. I have set it to 65 and 45 for elimination, 45w give a slight maximum speed reduction, neither setting makes any difference to disabling Cool and Quiet shuts down 2 cores.

                                 

                                PS mate, I think the PCIe bus issue is just misreporting now since the bios update they gave me was to fix that issue alone.. it still says 8x BUT when benching the gpu it's going to Gen 3 8x 8.0GT/s that's actually 16x?..

                                 

                                it's the other funnies heat issues, BSOD, clocking to 31x under load when it's meant to do 36x-40x  under load, performance less than a 7850k, the 2 cores shut down with C&Q etc that have me raising an alarm over this combo, and until someone comes and says well I got this exact pairing it works well can I really start looking at that cpu and saying hmm maybe you are faulty and it's my first one.

                                 

                                The refined power envelope they used to get to 65/45w in combination with this motherboard, I think is likely the issue. I have got a gut feeling the MB is reporting wrong to the OS, OR to the cpu or visa vie the correct thermals against voltages for the cpu and it's designed thermal and power spec perhaps?