1 Reply Latest reply on Mar 16, 2017 3:20 PM by nw9jajan

    RX 470 New Display Driver install Windows Crash

    nw9jajan

      Dear AMD!

      I wish give a feedback, to help resolving 1 problem with RX VGA.

       

       

      I have new ASUS STRIX RX470 4GB OC VGA. (Old AMD HD7850 1GB, working with no problem.)

      Gigabyte GA-970A-D3 rev1.4 motherboard (F13b latest BIOS)

      AMD FX8320 CPU.

       

      After I installed the new VGA, the first PC power on, I have a strange crashed startup picture. (The boot up is working well, only the startup pictures is corrupted.)

      When I switch off the startup picture, the BIOS message are correct displayed.

      I think the Motherboard BIOS don’t initializing in the first sec the VGA correct, so this causing the corrupted picture.  (This problem is not critical.)

       

       

      But the critical problem is:

      When I installed the new Crimson ReLive Edition 16.12.2 driver,(later same problem with the newest Crimson ReLive Edition 17.1.1 driver )

      before "setup" adding the new display driver,

      "setup" removing the old display driver, and the starting with the new display driver,

      I have the same crashed pictures. Windows is working in the background, but the monitor pictures is crashed.

      I think this is caused by the same problem as the BIOS start up pictures.

       

      So I waiting the "setup"  for install the new display driver and start the new display driver, then crash the picture, I reset the PC.

      Now the next start, pictures are working correct with the new AMD display driver,

      then I start "setup" again, but this time I don’t install the new display driver (why already installed) “setup” is going 100% and working everything 100% correct.

       

       

      I hope this help.

       

      Thank you for your help.

       

       

      I love the new AMD VGA. Its awesome.

       

      Crashed pictures are in the attachment.

       

      B.r.

      Nw9jajan