3 Replies Latest reply on Aug 2, 2017 1:24 AM by ghost942

    XFX RX 480 artifacts/corruption

    elrid

      I'm experiencing some serious artifacting/display corruption issues on desktop and in games with my new RX 480 and I would really appreciate some help narrowing down the cause.

       

      My specs:

      CPU:

      i5 2500k

       

      Motherboard:

      GA-Z68A-D3H-B3

       

      GPU:

      XFX RX 480 GTR Black Edition (8 GB, 1338Mhz)

       

      RAM:

      8 GB DDR3 1333

       

      PSU:

      Zalman ZM850-EBT(850W 80+ Gold certified)

       

      Display:

      Iiyama PL E2407HDS 1920*1080 tested with HDMI (native), DVI (native) and DP-DVI adapter

      Also tested with a different display via DVI (native) and DP-DVI adapter

       

      OS:

      Windows 7 x64 SP 1 (fully up-to-date)

      Driver version:

      17.1.1

      16.12.2

      16.11.5

      16.11.4

      16.7.3

      (all after clean install/uninstall/DDU sweep in safe mode)

       

      Already tried:

      Different driver versions (DDU/clean install) - no effect.

      Clean Windows install - no effect.

      Different display cables - no effect.

      Different display (NEC) - no effect.

      Connecting two displays at the same time (all possible combinations of DVI, HDMI, DP, etc.) - some effect - less artifacts on desktop which may or may not be related to the fact that the 480 doesn't downclock its memory and doesn't downvolt its core nearly as much in idle states when there are two displays connected to it. No effect in games though.

      Switching from BIOS (most up-to-date version) to UEFI - no effect.

       

      Except for the 480 my system is 100% stable - there are no issues whatsoever when I'm using my old GPU (225W TDP, DDU'd its driver before installing the 480, of course) or 2500k's IGPU (disabled it in BIOS and DDU'd its driver - no effect).