AnsweredAssumed Answered

RX 460 crash (black screen)

Question asked by nihal on Jan 15, 2017
Latest reply on Mar 14, 2019 by ratash

So, I put a new system together in December, yet I can't use it properly due a serious issue with my RX 460: It randomly crashes even on idle, freezing my system.

 

I did nearly everything possible and managed to extend the original window of time it took to crash after booting from 5min-45min to 5min-72h. I'm using two displays, one connected to the RX and the 2nd to the motherboard, using the i5 internal graphics to see what happens during the crash: The RX display turns black, the iGPU display remains active and I can see Windows frozen there.

 

I'm nearly certain it's a software issue. I believe I managed to survive a crash for the first time after stopping the AMD External Events Utility. For the first time the RX display turned black, but my system has not frozen and I saw the RX clock rise to 1212 MHz and the memory clock alternate between 300 MHz and 1750 MHz, and that's idling. It spent quite some time like this, then reduced the clocks back to normal levels, resurrecting the display connected to it. I can provide HWiNFO logs of the incident if needed.

 

Relevant information: When I normally crash I need to shut down the computer to force the RX to be detected again. If I only push the reset button when using the RX alone my system beeps for no video card. When I have the iGPU enabled upon reset I can get to BIOS and Windows, and the RX isn't detected.

 

Nothing wrong appears in my event logs when I crash. Before stopping the service the HWiNFO log wouldn't show anything abnormal either upon crashing, only without the service it managed to log the abnormal clock speeds. My temperatures are always good. The system never crashes when I disable the RX and use only the iGPU.

 

My system:

Gigabyte GA-H170N-Wifi

Intel i5 6600

Corsair 16GB DDR4 RAM

PowerColor RX 460 4GB

Corsair CX430

Windows 8.1 64bit

 

What I already tried and failed:

- Updated my chipset.

- Updated my Windows.

- Used the DDU Tool every driver I tried.

- Did a Windows 10 fresh install, updated it and installed the drivers manually.

- Tried the drivers 16.12.2, 16.12.1, 16.9.1, 16.7.2, always using the full package and uninstalling between each try.

- Cleared CMOS.

- Reflashed my BIOS. It's UEFI F4 (I can't update it to the F20, it can brick Skylakes).

- Took the RX off the slot and resat it a couple of times.

- Tried it without the iGPU enabled (obviously).

Outcomes