5 Replies Latest reply on Jul 3, 2017 3:54 AM by jasperwillem

    Cannot disable crossfire in Radeon Settings 16.12.2 global profile

    shajirr

      After installing the second RX 480 card, I cannot disable crossfire in the global profile - Radeon Settings program just freezes and crashes if I try to do it.

      Doesn't even show any errors, just closes itself, when I relaunch it crossfire is still enabled. I can only disable it in individual application profiles.

      The only way I can now disable it globally is to just physically unplug the 2nd card, which is quite stupid.

       

      What I tried:

      1) rebooting PC - doesn't work

      2) uninstalling all AMD drivers using the clean uninstall option from drives installer, rebooting, installing it back - doesn't work, still crashes.

      3) uninstalling all AMD drivers using the clean uninstall option from drives installer, rebooting to safe mode, running latest DDU to uninstall all AMD drivers, rebooting, installing Radeon Software again - does not work

       

      System: Win 7 x64

      Radeon Settings v 16.12.2

        • Re: Cannot disable crossfire in Radeon Settings 16.12.2 global profile
          amdmatt

          Thanks for the post. Please submit a bug report and roll back your driver.

          • Re: Cannot disable crossfire in Radeon Settings 16.12.2 global profile
            jasperwillem

            Dear all,

             

            Have had this problem for a while on my win 7 and win 10 desktop build with 2 bridged R9 280x cards.

            My solution was to quick reboot the pc before the freeze.

            However, today I did a reinstall and I am unable to quickreboot the system and I am stuck on the freeze.

             

            Hopefully will hear more.

              • Re: Cannot disable crossfire in Radeon Settings 16.12.2 global profile
                jasperwillem

                Hey all

                 

                By setting the WaitToKillServiceTimeOut on 500 for the shutdown procedure, with all stuff disconnected from motherboard outside essentials (mouse, keyboard, power, just 1 videoconnetor). (image; https://goo.gl/GBNXAE )

                I could get my computer to shutdown before the freeze and I am now again working with my 4 screens.

                Good to know, the moment you switch crossfire, shut down your pc with (i.e.) your power-button for shutdown.

                Then when the pc is shutdown the crossfire setting will be saved in the registry (or wherever it is saved).

                When your shutdown freezes before complete shutdown, find more to disable in your task manager to make sure your shutdown is as short as possible.

                When the shut down cycle is successful , then next boot will show the Crossfire is disabled.

                Then after first boot, connect all screens and reboot again before doing other stuff, to be sure all driver settings are stored the way you want.

                 

                Jasperwillem

                • Re: Cannot disable crossfire in Radeon Settings 16.12.2 global profile
                  jasperwillem

                  Hey all,

                   

                  Today Windows 10 got a big update and for the first time in ages I could switch into "non-cross fire mode" without a freeze.

                   

                  Jasperwillem

                  2 of 2 people found this helpful
                    • Re: Cannot disable crossfire in Radeon Settings 16.12.2 global profile
                      jasperwillem

                      With a complete other reason I read up on the following setting today; "turn on fast startup" in power-settings; https://puu.sh/wAm6g/9dd6ec8cdf.png


                      On HowToGeek it is explained that a the "fast startup" has the following consequences;

                       

                      1. "Fast Startup combines elements of a cold shutdown and the hibernate feature. When you shut down your computer with Fast Startup enabled, Windows closes all applications and logs off all users, just as in a normal cold shutdown. At this point, Windows is in a state very similar to when it’s freshly booted up: No users have logged in and started programs, but the Windows kernel is loaded and the system session is running. Windows then alerts device drivers that support it to prepare for hibernation, saves the current system state to the hibernation file, and turns off the computer.
                        When you start the computer again, Windows does not have to reload the kernel, drivers, and system state individually. Instead, it just refreshes your RAM with the loaded image from the hibernation file and delivers you to the login screen. This technique can shave considerable time off your start up.
                        "
                      2. "When Fast Startup is enabled, your computer doesn’t perform a regular shut down. Since applying new system updates often requires a shutdown, you may not be able to apply updates and turn your computer off. Restart is unaffected, though, so it still performs a full cold shutdown and restart of your system. If a shutdown doesn’t apply your updates, a restart still will."


                      So, when changing your driver settings results in a system freeze and you have a "half hibernation" enabled in your system settings, it maybe will boot/reboot with the last know "half-hibernation" file settings and you end in a loop that changes nothing. If I ever run in the problem again I sure will disable this to see if it resolves the problem faster.

                      1 of 1 people found this helpful