AnsweredAssumed Answered

ATI Radeon HD 5470 openGL problem ?

Question asked by kvexino on Jan 14, 2017
Latest reply on Jan 16, 2017 by kvexino

Describe your system:

  • AMD Graphics Card
    • ATI Mobility Radeon HD 5470 (5000 series)
  • Desktop or Laptop System
    • HP G72 b40sq
  • Operating System
    • Windows 7 - 64bit
  • Driver version installed
    • AMD-Catalyst-15.7.1-With-DOTNet45-Win7-64bit
  • Display Devices
    • Mobile PC Display / Samsung 173KT01-K01
  • Motherboard
    • Hewlett-Packard HP G72 Notebook PC
    • Mobile DualCore Intel Core i5-480M, 2933 MHz (22 x 133)
  • RAM
    • 8GB - SK Hynix HMT351S6BFR8C-H9 and SK Hynix HMT351S6EFR8A-PB

Describe your issue:

  • Provide a detailed description of the issue you are experiencing and the steps required to reproduce the issue.

I will start by saying that this problem started one month ago suddenly after a clean reinstall of windows 7 64 bit, same as it was before.


The problem starts when i want to open OpenGL games, i get error such as atiumdag.dll failed to start.

I want to say that i have clean installed latest ati graphic driver which is 15.7.1 for my video card.

Latest driver Name : amd-catalyst-15.7.1-with-dotnet45-win7-64bit.exe

The driver was installed correctly and I am sure 100% because I clean installed windows and the video driver as first driver but still same error.

Now what i want to say is that when i install an old driver Name : ati_catalyst_10.7beta_opengl_es2.0_win7_vista.exe the game starts but

the image in game is shaking and i understand that is because the driver is too old... or maybe I'm wrong

I have noticed another thing that dxdiag64-bit is reporting : Approx Total Memory : 173 MB which is wrong (with the latest driver)

with the old driver ati_catalyst_10.7beta dxdiag-64bit is reporting more than 2GB's.


  • Details about applications/games affected (including version number)

Lineage 2 Helios

  • Graphical settings used in the application/game (resolution and 3D settings)

Default ones but i have tried to disable vsync to enable it even triple buffering but no chance.

  • If possible, include a screenshot or video link of the issue

of the issue


Here is the report of dxdiag64


Difference between display files :


opengl check :


Another issue :


Video issue with old driver (10.7 beta)