9 Replies Latest reply on Feb 6, 2017 2:15 PM by redfury

    AMD fury sapphire fury nitro and gigabyte P55-UD3 doesn't work

    masterpj55

      Hello everyone,

       

      Sometime ago I bought a new graphics card for my Gigabyte P55-UD3 motherboard.
      It has PCI-E 2.0 (16x) but inserting the card gives me an error beep code and a black screen.

       

      The card has been tested on another system and works. My Nvidia GTX 680 worked fine on this system and still works when I swap it back.
      I went out to contact gigabyte for support and they told me to update the bios and clear the CMOS and nothing else. My BIOS is already running the latest version (but should note there is no UEFI support). I tried running the system with the UEFI button pressed and unpressed and sadly no luck.
      My PSU is 750watts and should also be sufficient. My CPU is the intel I7 860

       

      Tested on windows 10

       

      Any ideas?

       


      edit: So I got the card to work.. as it wasn't spinning up (only giving a short nudge).
      It appears that it was because I used a 8 pin and 6 pin connector. I made 2 8pin connectors by using a seperate lose 2 pin connector to attach to the other pins.. It likely didn't work because the sense doesn't match or it's on the same rail but it made the card spin up (but resulted in artifacts). Putting the other card back and all was fine though. I just need to go get an adapter tomorrow to actually get 2 seperate 8 pin connectors!