11 Replies Latest reply on Jan 13, 2017 5:41 AM by redfury

    What driver should I install for Radeon HD 7340 using a Linux distro based on Ubuntu 16.04?

    pemartins

      These are my settings:

      • AMD Graphics Card: Radeon HD 7340
      • Desktop or Laptop System: ASUS X55U-SX038H
      • Operating System: LXLE 16.04.1 64bits, Kernel Linux 4.4.0.57-generic (x86_64)
      • Driver version installed: 00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 7340]
      • Display Devices: 1366x768
      • Motherboard CPU/APU: 2x AMD E2-1800 APU with Radeon HD Graphics
      • RAM: 4G

       

      Radeon driver, the one I'm using now and is installed with the distro by default for this video card, is very bad in streaming, it has a lot of choppiness and I cannot find a way to configure settings. It is way worst than the Windows driver.

       

      So like the title says, what driver should I install for Radeon HD 7340 using a Linux distro based on Ubuntu 16.04? And how to configure it?

       

      There is an attached file with "lspci" and "lspci -v" prints.

       

      Thank you very much in advance.

        • Re: What driver should I install for Radeon HD 7340 using a Linux distro based on Ubuntu 16.04?
          redfury

          Your card has Proprietary Linux Graphics Driver  only for Ubuntu 12.04.4 LTS, 14.04.2, 15.04

          I think you will never get such driver for 16.04 because your card has a legacy status since 03.2016 and will not get any driver updates in future.

           

          Radeon™ HD 8000 – HD 8400, HD 7000 – HD 7600, HD 6000, and HD 5000 Series

          1 of 1 people found this helpful
            • Re: What driver should I install for Radeon HD 7340 using a Linux distro based on Ubuntu 16.04?
              pemartins

              Thank you very much for getting back to me.

               

              That is a real deal breaker in terms of purchasing more AMD products in the future, for Windows a similar thing happened. But is there a way I can install an old driver, isn't it something similar to Windows 10 in which not only the latest drivers (16.xx) are not available for this card (despite the system saying there's an update), the 15.xx drivers work really badly but the old 14.xx drivers work perfectly?

                • Re: What driver should I install for Radeon HD 7340 using a Linux distro based on Ubuntu 16.04?
                  redfury

                  I don't know for sure. You can try install those drivers (from my link).

                  About AMD hardware... All cards with GCN1.1(and above) architecture have drivers for 16.04

                  I mean three years old hardware has full support from AMD for latest Windows and Linux systems. It is not so bad.

                  1 of 1 people found this helpful
                    • Re: What driver should I install for Radeon HD 7340 using a Linux distro based on Ubuntu 16.04?
                      pemartins

                      Once again thank you very much for your help.

                       

                      I tried to install this driver:

                      but I get this error message:

                      "ERROR: Please install the required pre-requisites before proceeding with AMD Catalyst installation. Please check file usr/share/ati/fglrx-install.log for more details.

                      Removing temporary directory: fglrx-install.fLW3lH"

                       

                      Then I went to check the mentioned log file, some required packages where missing, which I installed, but still I get this error:

                      "NOTE: If your system has logged the missing packages required for installation, install them in the order as per the log file to resolve package-dependency issues.

                      fglrx installation requires that the system has kernel headers.  /lib/modules/4.4.0-57-generic/build/include/linux/version.h cannot be found on this system.

                      Install kernel headers using the command apt-get install linux-headers-4.4.0-57-generic."

                       

                      But when I try to update it, the system says it's already up to date:

                      "$ sudo apt-get install linux-headers-4.4.0-57-generic

                      Reading package lists... Done

                      Building dependency tree      

                      Reading state information... Done

                      linux-headers-4.4.0-57-generic is already the newest version (4.4.0-57.78).

                      0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade."

                       

                      Do you know it manually installing any of the packages in the printscreen below can bypass this issue?

                       

                       

                      Or is there a version.h file I can just copy and paste in the required directory, since I have some files named version.h in my machine but none in that specific directory? Here's a print of the version.h files I have on my machine:

                      "$ locate version.h

                      /lib/firmware/carl9170fw/include/shared/version.h

                      /usr/include/SDL/SDL_version.h

                      /usr/include/alsa/version.h

                      /usr/include/btrfs/version.h

                      /usr/include/glib-2.0/glib/gversion.h

                      /usr/include/linux/version.h

                      /usr/include/linux/dvb/version.h

                      /usr/include/pulse/version.h

                      /usr/include/x86_64-linux-gnu/gnu/libc-version.h

                      /usr/lib/python3/dist-packages/lxml/includes/lxml-version.h

                      /usr/lib/x86_64-linux-gnu/perl/5.22.1/CORE/git_version.h

                      /usr/share/virtualbox/src/vboxhost/vboxpci/include/VBox/version.h

                      /usr/src/linux-headers-4.4.0-53/include/uapi/linux/dvb/version.h

                      /usr/src/linux-headers-4.4.0-53/include/xen/interface/version.h

                      /usr/src/linux-headers-4.4.0-53-generic/include/config/localversion.h

                      /usr/src/linux-headers-4.4.0-53-generic/include/config/arch/want/compat/ipc/parse/version.h

                      /usr/src/linux-headers-4.4.0-53-generic/include/config/isdn/diversion.h

                      /usr/src/linux-headers-4.4.0-53-generic/include/generated/uapi/linux/version.h

                      /usr/src/linux-headers-4.4.0-57/include/uapi/linux/dvb/version.h

                      /usr/src/linux-headers-4.4.0-57/include/xen/interface/version.h

                      /usr/src/linux-headers-4.4.0-57-generic/include/config/localversion.h

                      /usr/src/linux-headers-4.4.0-57-generic/include/config/arch/want/compat/ipc/parse/version.h

                      /usr/src/linux-headers-4.4.0-57-generic/include/config/isdn/diversion.h

                      /usr/src/linux-headers-4.4.0-57-generic/include/generated/uapi/linux/version.h"