1 Reply Latest reply on Apr 1, 2017 11:13 AM by kersus

    Application has been blocked from accessing graphics hardware

    teayeon

      AMD Graphics Card: AMD Radeon R7 Graphics

      Desktop/Laptop: Desktop

      Operating System: Windows 10 Home Edition

      Driver Version: AMD Crimson Relive Edition 16.12.2

      Display Device(s): Sony PlayStation 3D Display, 1920 x 1080 HD Resolution, HDMI adapter

      Motherboard: Gigabyte AMD FM2+, GA-F2A68HM-H

      CPU/APU: AMD A10-7890K, 4.1GHz w/ 4MB Cache + Wraith Cooler

      Power Supply: Insignia 520W Power Supply

      RAM: Corsair Vengeance Pro 8GB (2x4GB) DDR3 2400MHz C11 Memory Kit

       

       

      So here's a quick breakdown of my issue: I built and setup my computer yesterday after I picked it up from Memory Express; everything downloaded and installed properly. I am currently running the latest version of DirectX (12) and all my graphics drivers are updated to the latest version. I can basically open all of the clients for my games, but the game immediately crashes when I go into an actual game. This occurred with League of Legends (which my APU should be able to handle, no problems.) so I decided to test out Smite as well to see what happens. Same thing occurs: I get the "Application has been blocked from accessing graphics hardware" message. I've tried reinstalling my Radeon R7 graphics by uninstalling and then restarting my computer to reinstall it, I've tried doing TdrDelay, I've updated all of my drivers and what-not... I'm absolutely out of ideas. I can't even go into my graphical settings on League of Legends to tweak anything, but my Smite is running with the lowest settings possible and still crashing immediately when I launch into a game.

        • Re: Application has been blocked from accessing graphics hardware
          kersus

          Very similar issue here. AMD Radeon R7 250 series (msi) on Windows 10. Restarts when opening games (steam). Periodically get Radeon Settings: Host application has stopped working and every application gets Application has been blocked from accessing graphics hardware. The screen also flashes/blinks every few seconds when any application is open.

           

          If I remove all AMD software using DDU the screen is fine while utilizing the generic Microsoft display driver. If I reinstall the AMD driver, the problems return. I have made sure the OS is up to date and verified that .Net and Visual C is all good.

           

          It looks from a search that this problem has been going on for years with AMD. What is the fix?