3 Replies Latest reply on Jan 13, 2017 8:10 PM by piotrsb

    "AMD Settings" says I don't have Crimson ReLive Edition 16.12.2 Optional drivers, but raptr says I do. Also RadeonSettings.exe crashes

    piotrsb

      AMD Settings can't see my drivers.

      I've downloaded "Crimson ReLive Edition 16.12.2 Optional" Raptr program says that my drivers are up to date but this new "AMD Settings" program says "no graphic driver is installed (...)"  Also installing those drivers has removed catalyst control center for some reason. It is Raptr which sugested installing those drivers.

      After a few seconds RadeonSettings.exe (amd settings) crashes because it "stopped working".

      In my computer settings it says that my drivers date is 2014-11-20.

      I'm using desktop  Windows 7 64bit with Service Pack 1.

      Graphic card MSI Radeon R9 280X 3GB 384 PCI-E GDDR5 Gaming.

      RAM 12gb

      (couldn't find the rest of the information, should I attach a dxdiag file or something?)

       

      I've already tried removing every graphic driver there is and installing it all back again. Didn't fix the problem.

       

      Everything seems to be working fine. So far I only had problem with "Deus Ex Mankind Divided" game which crashes either on startup or after a few minutes of gameplay. Every information I've found said I need to update my drivers. So I tried to do so.

      I also consider buying a new graphic card but need to be sure first.