0 Replies Latest reply on Dec 29, 2016 11:45 AM by statesidemonk

    Sapphire Nitro RX 480 OC 8GB - Crashing

    statesidemonk

      Specs:

      OS - Windows 10 Home

      MoBo - Asus Z170-E

      CPU - Intel I5-6500

      RAM - 16GB (4x 4GB) DDR4 2666MHz

      PSU - Supernova 650 G2 (650w - 80 plus Gold)

       

      I've recently received the Sapphire Nitro RX 480 OC 8GB card (purchased on Black Friday, opened on x-mas), and have been experiencing some issues with it. The installation was simple and without without error, and my system recognizes the new card. I am also pleased with the high performance it offers. However, when running games, I am experiencing crashing. These crashes will occur as the games are launching, or after a few minutes of playing. What happens is the screen will display some artifacts, flicker, then will go to a blank screen. It even crashed once while using Firefox to research this issue.

       

      These crashes, for the most part, result in a full system crash, requiring me to turn the system off to reboot. On two occasions, the crash resulted in a blue screen with the error: "Thread Stuck In Device Driver". I checked, and there are no power-hungry programs running in the background, and during gaming, whether it is a light game or high-demanding title, the GPU clock maxes out.

       

      I've tried various troubleshooting techniques, but know have worked. I've tried rebooting my system, running anti-virus scans (and unplugged the Ethernet to rule out a mining virus), a clean uninstall/reinstall of the AMD drivers, a clean install of Windows 10, different monitor/cable configurations, I made sure that the card was properly seated and connected the the PSU, verified all my software and drivers were up-to-date. Nothing has worked. When I try using my previous graphics card (Radeon R9 380) the issue is completely absent, which makes me worry that my RX 480 card might be the problem. 

      Are there any other solutions to try, or is my card defective? Also, I have already cut out the barcode and submitted it to Sapphire for the rebate, so does this void the RMA?

       

      Thanks