0 Replies Latest reply on Dec 27, 2016 7:43 PM by voronsky

    Radeon RX 480 Missing Textures/Low res textures

    voronsky

      Greetings Everyone!

       

      I am currently playing an older game called "Freelancer" made I believe in 2003-2004. I have noticed that in some portions of my game I have "white models" or extremely low resolution textures. Affecting the game's sliders don't do anything, and affecting the Radeon Settings do not do anything either. This image here shows what im referring to

       

      QaMthF6.jpg

       

      and

       

      d5lrDPg.jpg

       

      1st Image is the white model, and the 2nd image is an extremely blurred background texture.  Now the game's graphics are not that dated, to where the blurring should be a norm to say the least. I have looked into it, and it seems some community forums have been stating that it's an AMD driver related issue more so than a game one (If those links are needed I can provide them). Attached is a copy of my DxDiag. In addition I have tried some third-party software (RadeonMod, RadeonPro) to disable what some have blamed "Catalyst AI" forcing older games to use the lowest resolution as possible all the time, but those third party software have not made any changes in the slightest. Has anyone experienced this problem with older games in particular? and possibly solved it? I am using Radeon 16.12 drivers as well.

       

      Thanks for any help!