AnsweredAssumed Answered

BSOD thread stuck in device driver, i can't reinstall drivers

Question asked by misiek on Dec 27, 2016

Hi, at the beginning i am sorry for language mistakes.

 

From yesterday i've got a problem with my GIGABYTE Radeon R9 380 4GB. I closed down PC and a moment later i couldn't boot up Windows 10. All the time I've got BSOD with message: Thread Stuck In Device Driver. I am trying to solve this problem from hours, but without results. This forum is my the latest step before send card to warranty service. 

 

What i tried and what i discovered:

- I can run windows in safe mode

- When i uninstalled AMD drivers, i can run windows normally

- When i am trying to install drivers (the latest, which i had previously, older...) during installation i've got the same BSOD (sometimes gpu fans are going crazy - 100% fan, like first time when i've got this)

- Uninstalling drivers with DDU doesn't change anything

- Uninstalling Intel graphics drivers doesn't change anything

- I cleaned up my PC, I removed GPU from case, also cleaned by compessed air. No results. Btw. i care about PC and i am trying to keep it clean all the time.

- I flashed the latest VBIOS

- GPU "works" normally, it means that backlight and fans works.

- After all i removed raptr manually from register. No results.

- Uninstalling Realtek HD Audio drivers doesn't change anything.

- I don't overload this PC, i even didn't OC it. From few month i just play games average few hours in week.

 

I didn't change anything manually yesterday, but i saw, that there was windows update :/ I've tried to check what was changed, but i don't know how to check it. As i said, i just boot up PC for a while to check something and after reboot (close down and power up after few minutes) i've got this problem.

 

My PSU: OCZ /Fire Power CoreXStream Series 500W ATX

Outcomes