12 Replies Latest reply on Feb 17, 2017 10:54 AM by nunnah67

    RX470 goes black screen with "no signal" until switching PC off and on

    glcoder

      Hello. I've got a problem with my RX470 and latest AMD drivers (Crimson ReLive Edition 16.12.1). In several games I've getting black screen with "no signal" on monitor, It occurs at a certain point in different games (such as Dying Light, Heroes Of The Storm, Rising of The Tomb Rider, and some others), so I was able to 100% reproduce it. It happens with ReLive enabled or disabled. Rebooting my PC doesn't help, only switching it off and on again. At first I was thinking of overheating and I used Open Hardware Monitor to log sensor data, after the crash I opened the log and saw that temperature before crash of CPU (50-60 C) and GPU (50-52 C) was just fine, but at the moment of crash GPU temperature sensor is reporting 500 C and no data from other sensors, that's just weird. And this is never happened outside of a game. After I've downgraded to previous AMD driver (Crimson Edition 16.11.5 Hotfix) things goes just fine, no crashes, no black screen, everything is fine. So I think this is an driver issue. I can provide additional info if you want.

       

      You can see sensors data from one of the crashes here.

       

      Specs:

      CPU AMD FX-8350

      GPU ASUS ROG STRIX-RX470-O4G-GAMING

      MB ASUS M5A99FX PRO R2.0

      PSU 550W Corsair CS550M

      RAM 16Gb DDR-III 1866MHz Crucial Ballistix Tactical (BLT2CP8G3D1869DT1TX0CEU)