7 Replies Latest reply on Jan 18, 2017 4:17 PM by ray_m

    Latest AMD drivers for 2x HD 6850 Crossfire.

    juanigonzalezc

      I have 2 Sapphire Radeon HD 6850 in Crossfire that work fine, but for certain games (Fifa 17 in particular) it is required the 16.30 version of AMD drivers and the 6850 only supports until 15.2.

       

      I've read in some posts that since the 6850 doesn't meet the minimum requirements I shouldn't bother, but the 2 GPUs in Crossfire do, so there should be a way to solve this.

       

      Any suggestions?

       

      Thank you in advance.

       

      Regards, Juan.