6 Replies Latest reply on Mar 8, 2017 10:30 AM by redfury

    amdgpu-pro-16.50-362463 crashes Desktop env on Ubuntu 16.04

    temposuender

      got an AMD A10-7860K Radeon R7 running on Ubuntu 16.04

      Kernel 4.4.0-31-generic

      Was fine on amdgpu-pro 16.40-348864 upgraded to amdgpu-pro-16.50-362463.tar and it's crashing. Doesn't even allow me to go to the console unless booting in emergency mode.

       

      Trying to get to the logs and will update as soon I got hands on some useable info from there.

       

      Update: either the driver is a piece of heap of s**t or AMD removed support for my card from 16.50

       

      amdgpu 0000:00:01.0: GPU fault detected: 146 0x03070014

      amdgpu 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x0010541D

      amdgpu 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x07000014

      VM fault (0x14, vmid 3) at page 1070109, write from 'CB0' (0x43423000) (0)

      amdgpu 0000:00:01.0: GPU fault detected: 146 0x07a70014

      amdgpu 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x00000000

      amdgpu 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x07000014

      VM fault (0x14, vmid 3) at page 0, write from 'CB0' (0x43423000) (0)

      amdgpu 0000:00:01.0: GPU fault detected: 146 0x08870014

      amdgpu 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x00104A45

      amdgpu 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x07000014

      VM fault (0x14, vmid 3) at page 1067589, write from 'CB0' (0x43423000) (0)

      amdgpu 0000:00:01.0: GPU fault detected: 146 0x00270014

      amdgpu 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x00000000

      amdgpu 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x07000014

      VM fault (0x14, vmid 3) at page 0, write from 'CB0' (0x43423000) (0)

      amdgpu 0000:00:01.0: GPU fault detected: 146 0x03030014

      amdgpu 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x00105B18

      amdgpu 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x03000014

      VM fault (0x14, vmid 1) at page 1071896, write from 'CB0' (0x43423000) (0)

      amdgpu 0000:00:01.0: GPU fault detected: 146 0x0aa30014

      amdgpu 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x00106B55

      amdgpu 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x03000014

      VM fault (0x14, vmid 1) at page 1076053, write from 'CB0' (0x43423000) (0)

       

      apt purge amdgpu* and reinstall amdgpu-pro 16.40-348864 brought the system back.