12 Replies Latest reply on Feb 12, 2017 5:00 AM by nacevedo

    Unable to Successfully Update to 16.12.1

    symbiotic

      Good afternoon,

       

      For the last few days I have been trying without success to update my drivers from 16.11 to 16.12. Whenever I do, the installation seems to go alright, but my screen doesn't flicker (indicating a new driver being installed), and the AMD Software application tells me at the end of the process that 16.12 has been partially installed, or not installed at all. I have since done a Clean Uninstall using the AMD Cleanup Utility, and the software is now failing to detect any driver past my base driver (16.5). It simply shows up as "Local Driver". Here is what I have tried:

       

      Update (3:20pm EST): Running the Automatic detection tool again changes the "Local Driver" message to "Recommended: 16.12".

      Update (6:30pm EST): I've successfully upgraded to the previous driver version, 16.11.4, where I will remain until I can manage to find a solution to this.

       

      AMD Crimson ReLive Minimal Setup web.exe (The automatic detection tool)

      AMD Crimson ReLive Minimal Setup 64bit.exe (The manual driver I downloaded)

      Win 8.1 64bit Radeon Software Crimson ReLive Dec.7.exe (The full version of the above)

       

      Attached, I have also included the error report from my last attempt at installing 16.12.

       

      These are my system specs:

      AMD Radeon HD 7770, Desktop

      Windows 8.1 64-bit

      Current Driver: 16.50.2001, "Partially Installed", Click Here for an image

      Asus VS247 1920x1080 @64Hz, non-HDMI

      Gigabyte GA-78LMT-S2 Micro ATX AM3+ Motherboard

      AMD FX-6100 3.3GHz 6-Core OEM/Tray Processor

      Cooler Master i500 500W 80+ Bronze Certified

      8GB of RAM

        • Re: Unable to Successfully Update to 16.12.1
          black_zion

          The AMD Cleanup Utility is outdated and does not work properly with any Crimson release. Have you tried the Clean Install option on the 16.12 installer?

          • Re: Unable to Successfully Update to 16.12.1
            symbiotic

            kingfish I have indeed updated Win8.1 completely, and even though Black_zion already suggested a clean install, I will try it again soon and see if it works. For now, i'm still rooted on 16.11.4.

            • Re: Unable to Successfully Update to 16.12.1
              kagerro

              I've been struggling with this same issue and I finally delved back into attempting to solve it. Seems I've done just that finally, for me anyway. Hopefully it's the same issue for anyone else out there. I ended up fixing it by going to C:\Program Files\AMD in there, there is a folder in which I had no permissions to, I think it was called CNext, which just so happened to be the folder where AMD settings installs to. If you see a folder icon with a lock, that means you have no permission to change it, which means no uninstalls or reinstalls will truly be effective cause you are unable to change it in that state. Right click on it and go to Properties and then click the security tab. Click edit and click the checks for each group or user to allow full control. If that doesn't straighten it out, go back to the security tab but this time go to Advanced and take ownership and permissions back over, then reinstall and hopefully have a happy day again. Goodluck, hope this helps!

              • Re: Unable to Successfully Update to 16.12.1
                avroarrow

                I can attest to the fact that this is also true for the A-Series.  My A8-3500M has the same problem.  AMD stuck me with driver v15.200.1062.1004 for the Llano's Radeon HD 6620G.  Meanwhile, v16.10.1 seems to work just fine for my gaming desktop with my twin HD 7970's in Crossfire.  It's a pain because I can't enable DXVA2-Native in my codec pack to reduce the strain on the old Deneb-class Quad-Core CPU side without having completely up to date drivers.  My laptop isn't for gaming so 2D playback tweaks actually matter.  It's ironic that the newer drivers work on my desktop because software decoding with an Octocore FX-8350 is a piece of cake compared to doing it with what is essentially a Phenom II X4 1.6GHz.  Here's the specs of both machines:

                 

                Craptop:

                Acer Aspire 5560-sb401

                AMD A8-3500M (Radeon HD 6620G)

                6GB RAM

                 

                Desktop:AMD FX-8350 (Stock-clock, Zalman Liquid Cooler)

                Gigabyte GA-990FXA-UD3

                2 x Radeon HD 7970 3GB GDDR5 VRAM

                16GB UMAX Cetus DDR3-1333MHz System RAM

                 

                Both systems run Windows 7 Ultimate x64.

                 

                EDIT: I just noticed something.  The driver installed said something about not having .NET Framework v4.5 installed.  Try updating your .NET Framework.  I just downloaded it quickly from Filehippo, we'll see what happens.  Whatever happened to the good old days when ATi used to bundle the latest version of .Net Framework with Catalyst if it was needed?

                • Re: Unable to Successfully Update to 16.12.1
                  nacevedo

                  Hi, I can confirm on Win10 x64 the issue still remains whatever I do: uninstall the driver and install from scratch or trying to update from Radeon settings. from more than 2 months the Crimson stuck on 16.9.2

                  Checking the driver version on Device manager I get the 21.19.137.1 with date at 16/09/2016 so is a very bad bug.

                   

                  OS: Windows 10 HSL

                  Proccesor: AMD A8-6410

                  Graphic: Radeon R5

                  • Re: Unable to Successfully Update to 16.12.1
                    symbiotic

                    Update: 1/23/2017, 1:42am: I have successfully updated from 16.11 to 17.2 with no problems using a Clean Install. It seems whatever problem 16.12 was having is now able to be bypassed.

                    • Re: Unable to Successfully Update to 16.12.1
                      nacevedo

                      Hi. I still have the same problem so I will try again a clean installation.

                      • Re: Unable to Successfully Update to 16.12.1
                        nacevedo

                        Good, after a very long tries to update the driver I could updste it to 16.12.2 but with a very big issue: I cannot configure the screen brightness. It got in default 25% so this is a new bug on driver.