5 Replies Latest reply on Dec 12, 2016 6:24 AM by isher

    R9 270X with Windows 10 and 16.12 drivers

    isher

      Originally, this computer started out as having Windows 7, with R9 270X's Crossfire.

       

      Drivers were no issue upgrading to 10, and worked fine, even as I updated.  I have had to completely reinstall 10 recently, and I cannot get the driver to install whatsoever.  Everything else--AMD Crimson, HDMI Audio Driver, Application Profiles--all install just fine.

       

      However, when it comes time to install the driver, it hangs and then will bluescreen with a SYSTEM_THREAD_EXCEPTION error involving the driver and reboot.  Then it just constantly bluescreens again, and again, and again until it finally goes into repair mode.  A clean install solves nothing.

       

      What I have tried:

       

      - System Restores and reinstall
      - Running DDU in Safe Mode and re-trying

      - Disabling the second card

      - Using Device Manager

      - Disabling automatic driver updates through Windows

      - Manually installing drivers with Device Manager

      - Using AMD's Autodetect

       

      Every.  Single.  Time.  Same exact thing.  I have read countless places, and the only thing I have not done is sfc in command prompt.  This was not an issue until I had to clean install Windows 10.  I've even tried using an older driver, and it behaves in the same fashion.  I should also add, it will say "AMD R9 200 Series" under display adapter, with an error code 43, no matter what I attempt to do.

       

      This was not an issue until fresh install of Windows 10 was done.  Do I just need to move on to another, newer card?  I am at my wit's end as to what to do.  If it is not actually supported, AMD should really consider re-evaluate listing it as supported hardware with Windows 10 drivers...

        • Re: R9 270X with Windows 10 and 16.12 drivers
          jigzaw

          Please try this: Go to>Settings>System>About>System Info>Advance system settings>Hardware>Device Installation Settings> Tick No>Save Changes. Install Crimson 16.12.1. Windows 10 1607AU is really different from 1511

          • Re: R9 270X with Windows 10 and 16.12 drivers
            isher

            Welp.  I'm still at a loss.

             

            This is the event it causes every time I try to install the driver:

            Log Name:      System

            Source:        Microsoft-Windows-WER-SystemErrorReporting

            Date:          12/11/2016 2:19:39 PM

            Event ID:      1001

            Task Category: None

            Level:         Error

            Keywords:      Classic

            User:          N/A

            Computer:      DESKTOP-PMH1O9E

            Description:

            The computer has rebooted from a bugcheck.  The bugcheck was: 0x0000007e (0xffffffffc0000005, 0xfffff805a458bcd5, 0xffff9f81208c5cf8, 0xffff9f81208c5520). A dump was saved in: C:\WINDOWS\MEMORY.DMP. Report Id: 504654a9-3854-4768-8d79-361775be611b.

            Event Xml:

            <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

              <System>

                <Provider Name="Microsoft-Windows-WER-SystemErrorReporting" Guid="{ABCE23E7-DE45-4366-8631-84FA6C525952}" EventSourceName="BugCheck" />

                <EventID Qualifiers="16384">1001</EventID>

                <Version>0</Version>

                <Level>2</Level>

                <Task>0</Task>

                <Opcode>0</Opcode>

                <Keywords>0x80000000000000</Keywords>

                <TimeCreated SystemTime="2016-12-11T22:19:39.679421700Z" />

                <EventRecordID>1494</EventRecordID>

                <Correlation />

                <Execution ProcessID="0" ThreadID="0" />

                <Channel>System</Channel>

                <Computer>DESKTOP-PMH1O9E</Computer>

                <Security />

              </System>

              <EventData>

                <Data Name="param1">0x0000007e (0xffffffffc0000005, 0xfffff805a458bcd5, 0xffff9f81208c5cf8, 0xffff9f81208c5520)</Data>

                <Data Name="param2">C:\WINDOWS\MEMORY.DMP</Data>

                <Data Name="param3">504654a9-3854-4768-8d79-361775be611b</Data>

              </EventData>

            </Event>

             

            And I am at a loss of what to do.  NOTHING works, old drivers cause the same issue, device manager causes this, Catalyst and Crimson both cause this.  It also repeats this behavior whether 10 or 7 is installed on the hard drive.

            • Re: R9 270X with Windows 10 and 16.12 drivers
              jigzaw

              Hi Isher,

              Just like to know if your memory and cpu is overclocked. And please don't use AMD autodetect, use:

              Radeon™ R9 200, R7 200, R5 300, R5 240, HD 8500 - HD 8900, and HD 7700 – HD 7900 Series

               

              Are both of your R7 270X the same brand because asus tweak its bios

                • Re: R9 270X with Windows 10 and 16.12 drivers
                  isher

                  Yes, they are both MSI R9 270X running identical BIOS.  However, this occured with only one card even installed, no CrossFire and the second PCI Express slot empty.

                   


                  It exhibits this same behavior with a fresh Windows 7 install as well, if it's worth mentioning.  Nothing is overclocked, except I'm using an Intel XMP profile on the RAM.  I can try resetting the CMOS, as I haven't done that yet--but everything is running in Auto and stock.

                   

                  If it helps, my system build is as follows:

                   

                  MSI Gaming 970 mobo
                  AMD FX-8320 CPU

                  16GB (2x8GB) PNY XLR-8 DDR3-1866 (actually 1600 without XMP)

                  MSI R9 270X 2GB (Curacao)

                  Kingston Savage 460GB SSD