12 Replies Latest reply on Aug 6, 2017 9:10 AM by luchilucs

    AMD Radeon R7 260X (Boinare XTX) Random freezes

    luchilucs

      Hello guys, my name is Luca and my desktop PC keeps freezing/crashing randomly and I am forced to always reboot the PC.

      I have isolated the problem on my gpu with the AMD drivers. Using Linux drivers or Windows default ones this problem doesn't happen.

      Firstly (since I bought the gpu until some weeks ago) I thought the problem was the fast constant switching between the two states of the gpu memory (between 2d and 3d mode) and the difference between their values (from 150MHz to 1500MHZ). I thought the 2d mode values were too low. The only workaround I found back then was to overclock the gpu to use always the 3d mode (memory clock @6000MHz, core clock @1000MHz, 50-55 C° idle) with ASUS GPU Tweak and later with ClockBlocker.

       

      Describe your system:

      • RAM: 8GB (2x4GB) DDR3
      • CPU: AMD FX-8320 8-Core
      • Motherboard: Gigabyte GA-970A-UD3P
      • PSU: Thermaltake Hamburg 530W ATX 80+
      • GPU: Asus R7260X-DC2-1GD5
      • Monitor: Dell U2414H UltraSharp 1920x1080 @60Hz DP to DP
      • OS Edition: Windows 10 Pro N x64
      • OS Version: 1703 (Creators Update)
      • OS Build: 15063.502

       

      Radeon System Overview:

      • Radeon Software Version - 17.7.2
      • Radeon Software Edition - Crimson ReLive
      • Graphics Chipset - AMD Radeon R7 200 Series
      • Memory Size - 1024 MB
      • Memory Type - GDDR5
      • Core Clock - 1100 MHz
      • Windows Version - Windows 10 (64 bit)
      • System Memory - 8 GB
      • CPU Type - AMD FX(tm)-8320 Eight-Core Processor

       

      Radeon Software:

      • Radeon Settings Version - 2017.0720.1902.32426
      • Driver Packaging Version - 17.30.1041-170720a-316467C-CrimsonReLive
      • Provider - Advanced Micro Devices, Inc.
      • 2D Driver Version - 8.1.1.1614
      • Direct3D® Version - 9.14.10.01292
      • OpenGL® Version - 6.14.10.13491
      • OpenCL™ Version - 22.19.662.4
      • AMD Mantle Version - 9.1.10.0220
      • AMD Mantle API Version - 102400
      • AMD Audio Driver Version - 10.0.1.1
      • Vulkan™ Driver Version - 1.6.0
      • Vulkan™ API Version - 1.0.51

       

      Radeon Hardware:

      • Graphics Card Manufacturer - Powered by AMD
      • Graphics Chipset - AMD Radeon R7 200 Series
      • Device ID - 6658
      • Vendor ID - 1002
      • SubSystem ID - 0458
      • SubSystem Vendor ID - 1043
      • Revision ID - 00
      • Bus Type - PCI Express 3.0
      • Current Bus Settings - PCI Express 2.0 x16
      • BIOS Version - 015.039.000.007
      • BIOS Part Number - 113-AD55300-201
      • BIOS Date - 2013/10/23 06:56
      • Memory Size - 1024 MB
      • Memory Type - GDDR5
      • Memory Clock - 1625 MHz
      • Core Clock - 1100 MHz
      • Total Memory Bandwidth - 104 GByte/s
      • Memory Bit Rate - 6.50 Gbps
      • 2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0000

       

      AMD R7 260X reference and ASUS ones:

       

      Currently additional settings:

      1. I have disabled from startup the service "AMD External Events Utility"
      2. I have disabled hardware acceleration of the browser
      3. I have OC the gpu and memory clocks as follow:

      Core Clock (MHz)
      Memory Clock (MHz)
      300 400150 300
      550150 300
      690150 300
      7901500 1625
      8701500 1625
      9301500 1625
      9801500 1625
      1000 11001500 1625

       

      Notes:

      1. Many users have this problem, with different AMD gpus and driver versions: I can link these threads too, if that may help.
      2. Sometimes the hard-freeze comes together with a Windows BSOD "THREAD_STUCK_IN_DEVICE_DRIVER": I can upload the dump file if that may help.
      3. Some users guess the problem is related with the AMD driver known bug "[404660]: GPU gets stuck in a low power state after it was previously stressed to max power"

       

      vBIOS List:

       

      Update:

      1) I have found an older ASUS GPU Tweak version (2.7.0.9) that let you tweak the 2D values (clock and memory). I tried to set the memory value from 150MHz to 300MHz.

      Actually it goes directly to 1500MHz like it's locked to 3d mode always. I think this is related to the vBIOS/driver states that won't let values between the "written ones" 150MHz and 1500MHz.

      The temperature seems to stay around 45 °C in idle (before was 50-55 °C). This seems to be a better workaround that setting explicitly "3D mode always" from ASUS GPU Tweak.

       

      2) I have found that the location of the drivers in the registry is the one specified by "Radeon Hardware":

      "2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0000"

      Here there is a valued called "PP_PhmSoftPowerPlayTable" that states the PowerPlay states. You can modify this hex value (REG_BINARY) to bypass the BIOS settings.

      I tried to set the state frequency values from 150MHz to 300MHz. Here it is the exported registry value:

      Windows Registry Editor Version 5.00

       

       

      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000]

      "PP_PhmSoftPowerPlayTable"=hex:88,02,06,01,00,00,00,09,18,58,00,60,00,7d,00,00,\

        00,e8,03,58,00,00,80,02,00,12,00,00,02,00,3c,00,00,62,00,7f,00,00,af,00,0c,\

        00,af,00,bf,00,97,03,00,00,d6,18,00,00,d5,00,fe,00,09,01,00,00,63,01,00,00,\

        00,00,00,00,00,00,00,00,00,00,00,00,32,01,00,00,00,00,14,00,00,00,02,01,00,\

        00,02,01,02,00,03,09,b0,ad,01,c4,7a,02,02,10,00,0c,f8,00,c4,7a,02,20,10,00,\

        30,75,00,30,75,00,00,10,00,02,18,08,00,00,00,00,00,00,00,00,00,00,00,00,00,\

        00,00,00,00,00,00,00,00,00,00,05,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

        00,00,00,00,00,00,00,00,00,02,06,c0,12,a4,1f,48,26,d0,07,a0,0f,1c,25,48,26,\

        16,00,a0,03,02,00,20,bf,02,00,6c,01,d0,01,15,02,00,00,3f,02,69,02,08,30,75,\

        00,01,ff,0c,f8,00,02,ff,c8,2c,01,03,ff,cc,55,01,04,ff,18,73,01,05,ff,7c,8c,\

        01,06,ff,04,a0,01,07,ff,b0,ad,01,08,ff,02,30,75,00,84,03,c4,7a,02,a7,03,08,\

        30,75,00,01,ff,30,75,00,02,ff,30,75,00,03,ff,c4,7a,02,04,ff,c4,7a,02,05,ff,\

        c4,7a,02,06,ff,c4,7a,02,07,ff,c4,7a,02,08,ff,08,52,03,39,03,00,00,58,03,39,\

        03,00,00,aa,03,84,03,00,00,ee,03,c9,03,00,00,2d,04,0e,04,00,00,65,04,46,04,\

        00,00,97,04,72,04,00,00,c9,04,9d,04,00,00,01,01,ff,30,75,00,30,75,00,00,0a,\

        8c,b9,00,8c,b9,00,d8,d6,00,d8,d6,00,24,f4,00,24,f4,00,70,11,01,70,11,01,f8,\

        24,01,f8,24,01,80,38,01,80,38,01,08,4c,01,08,4c,01,70,94,00,70,94,00,c0,da,\

        00,c0,da,00,a8,61,00,a8,61,00,08,01,ff,00,02,ff,00,03,ff,01,04,ff,02,05,ff,\

        03,06,ff,04,07,ff,05,08,ff,06,06,03,01,01,01,07,01,08,01,09,01,01,01,00,07,\

        14,cd,00,7c,92,00,24,f4,00,8c,b9,00,34,1b,01,9c,e0,00,44,42,01,ac,07,01,cc,\

        55,01,f8,24,01,54,69,01,44,42,01,dc,7c,01,90,5f,01,08,01,ff,00,02,ff,00,03,\

        ff,01,04,ff,02,05,ff,03,06,ff,04,07,ff,05,08,ff,06,00,08,01,ff,c8,af,00,02,\

        ff,c8,af,00,03,ff,14,cd,00,04,ff,24,f4,00,05,ff,34,1b,01,06,ff,bc,2e,01,07,\

        ff,08,4c,01,08,ff,90,5f,01,00,08,01,ff,d8,d6,00,02,ff,d8,d6,00,03,ff,e8,fd,\

        00,04,ff,f8,24,01,05,ff,08,4c,01,06,ff,90,5f,01,07,ff,18,73,01,08,ff,dc,7c,\

        01,01,64,00,69,00,52,00,69,00,69,00,e8,03,6c,07,69,00,00,00,00,00,00,00,00,\

        00,00,00,00,00,00,00

      Now GPU-z shows me both the 300MHz and 1500MHz states and these settings seem stable (no freezes since two days). The temperature in idle is 37 °C.

       

      Edit History:

      1. Added system information.
      2. Changing description of the problem and questions.
      3. Added notes and additional currently settings.
      4. Added updates.
      5. 06/08/2017 Updated system info, added OC tables for gpu and memory clocks, updated tags, edited title.