2 Replies Latest reply on Oct 9, 2017 9:26 AM by grundibular

    Compatibility issue with Duet Display and AMD GPU drivers

    machlo

      Installing Duet Display (duetdisplay.com) on a system with AMD RX 480 GPU (latest drivers) causes restarts during boot up.

      Steps to reproduce:

      1. Install AMD GPU drivers for RX 480.

      2. Install Duet Display.

      3. Reboot computer.

      4. Computer reboots during Windows boot up.

       

      In order to make Windows booting properly again:

      1. Start in safe mode.

      2. Disable GPU driver.

      3. Reboot.

      4. Uninstall Duet Display.

      5. Enable GPU driver.

      If you try to enable GPU driver without uninstalling Duet Display then your computer will reboot.

        • Re: Compatibility issue with Duet Display and AMD GPU drivers
          amdmatt

          Thanks for the post, you can submit a bug report here.

          • Re: Compatibility issue with Duet Display and AMD GPU drivers
            grundibular

            Hi - literally signed up just to reply to this and make it more findable for those having the same experience. Here come the keywords...

             

            Duet display, duet ipad second monitor, amd drivers won't install, black screen, stuck on dots, computer crashes when installing latest amd gpu drivers, C6H ASUS Crosshair VI Hero no bios display port HDMI, windows reinstall fails at SECOND_BOOT_PHASE. (I may edit this with more later)

             

            TLDR: uninstall Duet Display before updating AMD GPU drivers.

             

            So, to my story - this has wasted at least 12 hours of my time. I purchased brand new upgrade hardware (ASUS C6H, Ryzen 1700, AMD Vega 64, M2 drive, nice Samsung monitor) and got bogged down in (what seemed to be) the upgrade circle of doom. I hooked up the new hardware with my existing Windows install, booted into it - oh no that's right. I couldn't boot into it until I flashed the C6H bios, then I could see the BIOS screen, tell it to use the correct disc (it was looking to boot from the empty M2 drive?!). Windows boots into a predictably wonky state - fine, I'm going to install all the drivers now.

             

            Tip: ASUS Crosshair VI Hero (C6H) with AMD Vega 64 will not show the BIOS menu (by default at least) through Display Port. Use HDMI. Not sure if this is a fault or not.

             

            Trying to install latest AMD drivers yielded a HARD reset during the GPU driver install phase - total reset/reboot. Black screen, no BIOS, no boot. On display port (see Tip 1 above!) the only way I could get BIOS to appear was to reflash the BIOS back/forward to a different version - every time I wanted to get the machine to boot!

             

            Did a fresh install of W10 onto the M2 drive (had to contact MS support to reactivate Windows because of the extensive hardware change - automatic support didn't work) and that worked AND allowed new AMD GPU drivers to install. Interesting.... identical hardware, fresh Windows, fine with new AMD GPU drivers.

             

            Back to the old Windows disc (I have programs and settings which would be a pain to reinstall/reinstate). Tried a fresh W10 install over the top of existing  (that's a thing now, apparently) but it failed at SECOND_BOOT_PHASE with an error indicating a driver problem. Well, quite. Next, I pulled out the AMD Vega 64 and put my old HD7850 in, then managed to install the last working driver I'd had on it - 16.2.x or thereabouts. That worked fine, and I could do the fresh install of W10 over the existing. Perhaps now whatever quirky thing in the old W10 install would be flushed out and the drivers will install... nope. Swapped the Vega 64 back in and had the exact same problem. Hard reset and Windows going back to Microsoft Default Display Adapter.

             

            Belatedly, I thought "The only difference between that fresh install of W10 on the M2 and this one are the programs installed", so I brought up Apps/Programs and trawled through them. Ah, Duet Display - that's a display related thing. Uninstalling it demands a restart, which signifies that it changes some fairly deep stuff on the system. With that gone, well, you know where this is going, latest AMD Vega 64 driver installed with no problems at all. Then a simple clone across (Samsung's own migration program) to the M2 drive worked perfectly.

             

            Hopefully this will help others facing the same issue.